powered by Jive Software

Asterisk Server Status is Disconnected at Asterisk-IM General Settings

Hi all,

I’'m currently testing on Asterisk-IM plugin.

I’'ve added one server and few phone mappings.

However when I mouse over on the server, the status

is disconnected. When I tried to dial from Spark i got,

‘‘undefined-condition(500) Not connected to originate phone server’’.

Asterisk server is up, and I’'ve tried making call using

2 Idefisk soft phones, they work fine. Based on Asterisk-IM

plugin README, it stated that Asterisk must be installed

with Manager API enabled. I’'ve set enabled=yes in the

manager.conf file. I think, the server status must be

connected to enable the calls to be made…

I even tried to make SIP-call using the enterprise edition plugin.

It didn’'t run smoothly, but at least I could make 1 call then later

I failed to make any call and have to restart Spark.

I really hope that anyone can help me on this. Thanks…

regards

-amie-

Hi all,

I followed the exact settings in below thread.

Thread: Incoming Call Managment http://www.igniterealtime.org/forum/thread.jspa?messageID=144901&#144901

manager.conf file.

enabled = yes

port = 5038

bindaddr = 0.0.0.0

displayconnects = yes

timestampevents = yes

secret = somepassword

deny=0.0.0.0/0.0.0.0

permit=10.12.0.1/255.255.255.255

permit=127.0.0.1/255.255.255.255

read = system,call,log,verbose,command,agent,user

write = system,call,log,verbose,command,agent,user

Now my asterisk server status at Openfire is green=connected.

Actually I’'ve created a user in manager.conf before, the differences are

the deny/permit part. I’'m new to asterisk, so my approach is more

on trial and error

But now, after configuring the phone mappings, I got new error

“undefined-condition(500) Unabled to dial extention 2222” at Spark

After reading few threads I’'ve found out that IM-asterisk plugin must be used

with hardphone, spark and openfire to work.

I tried to configure xpressa/pingtel hardphone to asterisk, still fail to get registered :I

I’'ll check that issue in other threads.

-amie-