powered by Jive Software

Atualizar versão Openfire 4.1.4 para 4.1.5

Boa tarde, Comunidade.

Tenho na empresa Openfire 4.1.4, instalado no Servidor Virtual Linux Ubuntu Server 64Bits. O Openfire está associado ao AD/DC, usuários e grupos são todos do Active Direct.

Qual seria o passo a passo para efetuar a atualização? Posso executar por cima sem risco de perder informações, grupos, contatos, arquivamento de conversas?
Se não tiver como explicar aqui na comunidade, onde posso encontrar o passo a passo? Desde já muito obrigado.

Bom dia amigo, como você tem integrado ao AD, atualizando ele você não perde nenhuma configuração, só verifica depois os compartilhamentos dos grupos se você usa, mas eu fiz aqui e não perdi nada tanto no linux quanto no windows.

Boa noite.

Obrigado pelas informações.

Efetuei primeiro em um servidor que tenho como homologação, vi que realmente não perde e não altera nada.

Executado no ambiente de produção com sucesso.

Olá, poderia me passar um passo a passo de como fez a atualização? tenho um centos 6.9, esta com openfire 4.1.4.

Bom dia amigo, do mesmo jeito que você instalou, é só rodar o instalador, ele vai detectar que já existe uma versão antiga e vai efetuar a atualização.

Bom dia,

Estou tentando atualizar no meu CentOs 6.9, não estou conseguindo, poderia me passar a forma que você fez para atualizar?

No meu caso quando tento fazer pelo comando rpm -ivh… diz que a versão conflita com a existente. Tentei também baixar o pacote .tar.gz e descompactar e copiar para /opt em seguida copiar do backup os seguintes arquivos de configuração:

openfire/enterprise
openfire/conf
openfire/resources/security
openfire/logs

Não obtive sucesso.

Boa tarde amigo, eu uso ubuntu mas seria o mesmo processo do centos, eu fiz com o arquivo deb, assim:

dpkg -i openfire_4.1.5_all.deb

Boa tarde.

Desculpe na demora na resposta.

Segue o que eu fiz:

BAIXAR INSTALAÇÃO:

wget http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire_4.1.5_a ll.deb

INSTALAÇÃO DO PACOTE:

chmod +x openfire_4.1.5_all.deb

dpkg -i openfire_4.1.5_all.deb

Observe se o download que ele vai fazer vai ser com esse nome de arquivo. Pode acontecer de vir com nome diferente, para identificar isso, dê o comando para listar o que foi baixado, no meu caso o comando foi “ls”.

Sucesso.

Eu acho que seu erro aqui pode ser que você deve usar rpm -Uvf em vez de rpm -ivh

-U é para atualização

olhe aqui:

http://download.igniterealtime.org/openfire/docs/latest/documentation/upgrade-gu ide.html

https://linux.die.net/man/8/rpm

Consulte o guia oficial de atualização aqui: Openfire: Upgrade Guide

Além disso, veja o meu guia de atualização do Ubuntu aqui (as etapas devem ser semelhantes no CentOS, mas você vai querer usar rpm em vez de dpkg): Guide / Tutorial / Writeup / Walkthrough / How to: Upgrade Openfire 3.10.2 to 4.1.5, upgrade PostgreSQL 9.3 to 9.5, Upgrade Ubuntu 14.04.1 LTS to 16.04.3 LTS

A atualização do openfire é fácil e indolor, e você não deve perder dados, usuários ou grupos. Eu atualizei minha instalação do Ubuntu (que usa usuários / grupos AD por LDAP) de v3.10.2 a v4.1.5 sem problemas.

No entanto, você sempre deve tirar um instantâneo, fazer um backup, ou testar primeiro em um sistema sem produção antes de tentar uma atualização.

Bom dia,

Realmente era isso que estava errando o comando tem que ser -U, deu certinho.

Muito Obrigado pela ajuda.

Obrigado pelo retorno, estava errando no comando, após seguir orientação do colega Daniel Castellanos, consegui atualiza com sucesso.