powered by Jive Software

Authorization Failed

Kinda of a strange problem, yesterday afternoon i installed openfire on our server, and spark on two client machines and everything worked beautifully using ldap with a shared contacts list(which is great). I left both clients connected over night, and this morning had to reboot the server due to windows updates(yay for windows). I restarted OpenFire, since its not installed as a service, and went to reconnect the clients and get the message “Authorization Failed”. Since this message i have completely removed openfire, mysql, and reinstalled both and have done the same for Spark on this machine and still get ‘Authorization Failed’ yet i know the communication with LDAP is working fine since i can login to the admin panel without a problem. Further research into it show this in the packet capture with wireshark, and hoepfully someone can explain whats going on?!

Sent: <stream:stream to=“192.168.0.1” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

Recv: <stream:error>Disconnected</stream:error></stream:stream>

Sent: <presence id=“0azX5-0” type=“unavailable”></presence></stream:stream>

After this is just sits for a bit, and then i get the “Authorization Failed”

Any help at solving this issue would be great, because we are in desperate need of a nice intercompany messaging system, and interested in the enterprise version as well.

Thanks in advanced