Automatically change to away when Windows is locked

It appears this is/was a feature in the past versions but on our Windows 10 PC’s this does not seem to work. I have tried ticking and unticking the ‘enable idle’ mode in preferences. Any other suggestions?

what version are you using?


odd. I’ll try to set up a win10 workstation tomorrow to test this on. I seems to be working fine with win7 and 8.1. did you upgrade spark from a prev version or is this a fresh install?

Did this work as expected with other versions of spark?

Filed a while ago [SPARK-1646] Not switching to Away mode when locking screen on Windows 10 - Jive Software Open Source

1 Like

This was installed fresh. That’s a bummer that it is related to Windows 10 and working on other operating systems. Maybe I can do a workaround by adjusting idle timer to say away at an earlier/faster pace.

Is this really such a critical thing to go away when locking? It will still eventually go into away after idle time. Even when a person you are trying to contact is sitting in front of his PC he may still be busy and won’t reply, although he is shown as online/available. Setting idle time to a lower time might be more annoying.

As a work around, you may try disabling the lock screen.


ok…set up a win10 vm today.

background. The idle code looks for a mouse pointer location. when the screen gets locked, windows sets a specific location ,which in turn triggers the change in presence.

now…with windows 10, the lock screen has the wallpaper overlay, which doesn’t change the mouse location…however when you go to the “true” lock screen, the mouse location changes to what spark is looking for, and fires off the change in presence.

The above workaround works. It will still lock/password protect the workstation, but disables the wallpaper overlay.

Unfortunately, this may take a while to get fixed as Spark doesn’t have a lot of help right now. If you know of any java devs, please reach out to them for us!