powered by Jive Software

Basic setup problem - need help!

I’'m setting up a Jive server to act as an IM server for a game application that will be hosted on a public website (i.e. only those logged into the game can chat via the server).

I’'m having problems setting up the server and connecting from a remote game client. I have tested this in my local development environment - ServerName = 127.0.0.1 - and it works great.

I have set up a server and have DNS set-up to point my domain to my static IP address at the webserver. I have installed the jive server and have run setup. I set my Server Name to be my domain name. I have opened up ports 5222, 5223, 5269, and 9090 on my firewall and pointed them to my server’'s LAN address (192.168.x.xxx).

A problem seems to be that under Server Ports in the Server Settings section of the Jive Admin console, the IP:Port, Security settings all are set to 127.0.0.1:5222, NORMAL or whatever the respective ports are, instead of pointing to my server’'s LAN address (which the firewall is pointing to for each of the IM ports above). This seems to suggest that the Jive Server will not see communications coming through the firewall to port 5222, et. al.

Does anyone know what might be wrong with this setup, and/or how to change the IP:Port, Security ip address. When I try Edit Properties under Server Settings, I can only change the Server Name, which does nothing for IP:Port, Security settings. On my local dev environment, the IP:Port, Security setting automatically seems to resolve to my dev machine’'s LAN address.

Thanks in advance for all help.

Hi bmagierski,

We’'re working on tracking down a similiar problem in url=http://www.jivesoftware.org/community/thread.jspa?threadID=16001this thread[/url]. Which OS are you using?

Thanks,

Ryan

Hi Ryan,

Thanks. I just noticed that thread and am now following it. I’'m running Linux Fedora core 3 on the server wit the external problems. My local dev environment that was working is Mac OSX 10.4

I’'ll switch to following the other thread now …

– brian