powered by Jive Software

Beginnerproblem?

Hello,

this is the first time I’'m using a custom library and I have run in some problems.

I have standard java SDK 1.4.2 installation with a classpath environment variable set to my SDK folder. So far, I can use everything from the SDK without a problem.

Yesterday, I downloaded smack, put the *.jar files into a folder called jabtalk and started creating a simple program to test if it could access the smack lib.

import org.jivesoftware.smack.*;

public class JabTalk {

public static void main(String [] args) throws Exception

{

XMPPConnection conn = new XMPPConnection(“Jabber.org”);

}

}

I could compile it with:

javac -classpath c:\jabtalk\smack.jar JabTalk.java

I could compile it but the moment I want to run the program I get this error:

Exception in thread “Main” java.lang.NoClassDefFoundError: JabTalk

I tried running with and without the classpath flag but I still end up with this error.

Can someone help me out here?

solved.

forgot to put a semicolon on the end of that java -classpath

tried some stuff in the past 40mins or so.

smack really kicks butt!

" Welcome to the Java world! "

Hehe Someone said this to me last year on this forum when I was starting out with Java. Look! I’'m still around!

Have fun - Java is awesome

Adam