Best practises...?

new Object() —> {}

new Array() —> []

Not just for readability, but for performance too: l

This is an bug report if nothing else.

Attached a diff to make the following changes based of readability and Flex Coding Conventions:

  • new Array() --> []

  • new Object() --> {}

  • evt --> event.

Additionally, but not in this patch, would be nice to have consistency throuh the library. Like line endings and curly braces on the next line versus same line.
2009-04-01.diff (29542 Bytes)

Anyone with commit access care to apply the diff?

Patch updated.
2009-06-01.diff (27168 Bytes)


I filed this as: XIFF-50