powered by Jive Software

Bin/messenger Script for Linux in nightly builds and cvs

Hi,

I’'m missing the nice bin/messenger Script for Linux in the nightly builds and cvs.

If I copy it from the stable version it stops with an error messages:

/messenger/target/bin # ./messenger start

Starting messenger

/messenger/target/bin # nohup: appending output to `nohup.out’’

/messenger/target/bin # tail nohup.out

Exception in thread “main” java.lang.NoClassDefFoundError: com/install4j/runtime/Launcher

What’‘s wrong here or why isn’'t the messenger Script included in source and cvs?

Regards,

Frank

Hi,

does nobody has a hint how to get the bin/messenger Script working with the CVS version?

How is this done if a new version gets released from CVS?

Regards,

Frank

Frank,

One thing you could do – instead of copying the script to the nightly build, copy the JAR files from the nightly build into a normal Jive Messenger installation (delete all of the old JAR files first). I’'m fairly sure this should work.

We’'ll also look at improving the scripts in the nightly builds in the future.

Thanks,

Matt

Hi Matt,

I’'ve tried your solution today and it worked very well

One thing I don’'t understand: There are two JAR-files that are not present in both directories (package and cvs):

./.install4j/i4jruntime.jar only in the packet

./jspc/admin-jsp.jar only in CVS

Do I have to matter about them?

Regards,

Frank

This is what I found… just to share.

When you unzip and untar the file I assume then you create the /opt/ directory that you want to move to.

If you cd into the newly created (untared)… For example

tar -xvf wildfire_2_6_0.tar

x wildfire, 0 bytes, 0 tape blocks

x wildfire/.install4j, 0 bytes, 0 tape blocks

x wildfire/.install4j/i4jruntime.jar, 322850 bytes, 631 tape blocks

cd wildfire

Then do a mv * /opt/newwildfire/

the .installj4j directory doesn’'t get moved because it is a dotted directory… so after these steps you have to

mv .install4j /opt/newwildfire/

move the install4j specifically