powered by Jive Software

Blank contact list

Hello all!

3 days ago ~150 users (from ~400 total) had their contact list blanked when accesing from certain locations. If I access from another location with same JID, the contacts are showed. My first try was to look the logs, but didn`t found the causes. After, I upgraded to 3.6.2 (from 3.5.2), but the problem remains.

If it helps, I use these plugins: asterisk im (tried to disabled, but does not solve), broadcast, gateway im, monitoring service, open archive, sip phone plugin, search, user service.

If you have any hint, it will be welcome.

Thank you!

I forgot to say:

It happens with any clients, at least I tried pidgin and spark.

Where it works, both clients works, where it doesn`t work, no client works, I only get a blank contact list.

Hi Antonio,

disable compression on http://server:9091/compression-settings.jsp

Take a look at http://server:9091/system-cache.jsp - maybe there is a problem with the caches. Purge them all and watch them increasing again.

Take a look at http://server:9091/index.jsp - do you still have some free memory there?

Enable also the debug log for an hour, maybe something useful gets logged there.

LG

Hi LG,

thank you.

I will try it and post back the results.

cheers,

Tom Lobato

I tried these steps, but the problem remains.

On these clients, all other internet services (mail, web, etc…) are working well. Only jabber clients (tried several: Spark, Jajc, Pidgin, etc…) presents problems: It connects, but has a empty contact list. If I log in with the same jid/password from another place, all works fine (connects and shows contact list). I already tried to re-install the clients, but problem rmains.

I tried to trace the specific logs of the user mer_barreiras-uiara. If needed, both files are attached.

debug.log:

2008.12.10 12:50:36 1966940 (01/08/00) - Connection #6 tested: OK
2008.12.10 12:50:36 AuthorizationManager: Trying Default Mapping.map(mer_barreiras-uiara)
2008.12.10 12:50:36 DefaultAuthorizationMapping: No realm found
2008.12.10 12:50:36 AuthorizationManager: Trying Default Policy.authorize(mer_barreiras-uiara , mer_barreiras-uiara)
2008.12.10 12:50:36 DefaultAuthorizationPolicy: Checking authenID realm
2008.12.10 12:50:36 1966940 (01/08/00) - Connection #7 tested: OK

2008.12.10 12:50:45 1966959 (01/08/00) - Connection #9 tested: OK
2008.12.10 12:50:45 msn: rosterLoaded mer_barreiras-uiara
2008.12.10 12:50:45 msn: rosterLoaded mer_barreiras-uiara
2008.12.10 12:50:45 msn: rosterLoaded mer_barreiras-uiara
2008.12.10 12:50:45 1966959 (01/08/00) - Connection #10 tested: OK

In warn.log, but ~3:30h before, I got a message for the IP of the user mer_barreiras-uiara:**
**

2008.12.09 09:02:07 No ACK was received when sending stanza to: org.jivesoftware.openfire.nio.NIOConnection@175459b MINA Session: (SOCKET, R: /201.91.219.145:1062, L: /192.168.100.50:5222, S: 0.0.0.0/0.0.0.0:5222)
2008.12.09 09:03:14 No ACK was received when sending stanza to: org.jivesoftware.openfire.nio.NIOConnection@74d632 MINA Session: (SOCKET, R: /189.22.126.4:1838, L: /192.168.100.50:5223, S: 0.0.0.0/0.0.0.0:5223)
2008.12.09 09:09:11 No ACK was received when sending stanza to: org.jivesoftware.openfire.nio.NIOConnection@bf9569 MINA Session: (SOCKET, R: /200.161.0.227:1646, L: /192.168.100.50:5223, S: 0.0.0.0/0.0.0.0:5223)
**2008.12.09 09:15:35 No ACK was received when sending stanza to: org.jivesoftware.openfire.nio.NIOConnection@163dfde MINA Session: (SOCKET, R: /200.223.102.26:1267, L: /192.168.100.50:5222, S: 0.0.0.0/0.0.0.0:5222)
**2008.12.09 09:15:54 Invalid presence type
java.lang.IllegalArgumentException: No enum const class org.xmpp.packet.Presence$Type.invisible
at java.lang.Enum.valueOf(Enum.java:196)
at org.xmpp.packet.Presence$Type.valueOf(Presence.java:322)
at org.xmpp.packet.Presence.getType(Presence.java:107)
at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:229)
at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:176)
at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:133)


warn.log.zip (70045 Bytes)
debug_2.log.zip (39232 Bytes)

I have this SAME exact issue, only on a smaller scale.

It started a few days ago — In this case, ALL clients are using SPARK 2.5.8 except for one. ME. I am using 2.6 beta.

I was using 2.5.8 prior when the issue started, (I am one of the affected), uninstalling and removing reg keys to 2.5.8 and installing 2.6 SEEMED to have resolved the issue.

However, after a few days of working as expected, the system was restarted, no other changes had been, and starting the client afterwards I seem to have lost the contact list again. All of the GROUPS NAMES appear, just no one is in them.

Client logs in correctly.

Changing to a different user yields no difference in results.

Those without the issue continue with no noted problems.

SparkWEB client works as expected.

Smartphone client works as expected.

Not even sure where to start since a NEW installation on the same system worked for a few days with no issue, and others using same setup have no issue noted.

Anyone else having this issue show up?

Where did you find these “reg keys”?

Hi Antonio,

did you try to disable the IM plugin or other plugins? Your debug.log looks bad, there are 1228 lines with timestamp “2008.12.10 12:50:07” which contain either “Connection #? tested: OK” or “#n registered a statement as closed which wasn’t known to be open. This could happen if you close a statement twice.”

I wonder how much CPU and IO your server is using while processing / logging so much.

LG

I disabled asterisk and gateway IM plugins, but didnt solve. I didnt disabled some others: archive, http admin, search… I don`t know if I should.

I looked up /var/log files: kernel.log, syslog, messages, debug and didn`t find errors regarding cpu or mem.

My scenario:

Intel® Pentium® 4 CPU 3.40GHz

1.5GB RAM

2 HD Sata 80GB with software RAID (mdadm)

Debian Linux 4.0 (Etch)

Mysql 5

I have ~900 users, but only 400 stay online at work time all days.

So, I don`t think the hardware is overloaded.

I will try to install openfire from scratch again. But now, I will create all users and Rosters (each user has all others) from a backuped list, not restoring the DB, but creating a fresh DB schema and populating with http admin plugin. And the rosters I made a perl/mysql script to add all users to other one contact list.

Hi Antonio,

you may want to enable the debug log again and identify the plugin which is logging there so much by deleting plugins until the debug log is no longer written. Then you can install all other plugins again.

Did you run “vmstat 1 1” to monitor the current usage? I expect that you are currently using more than 10% CPU for Openfire.

LG

Hi LG!

As I was under the gun regarding my customer, I had no much time for debug. Yesterday I reinstalled openfire with a fresh config and empty db, then I added all users via user service plugin. ofRoster and ofRosterGroups ware restored by scripts. And it worked.

Anyway, thank you very much for your great help!

I didn`t run vmstat before reinstall.

A question: as you sugested about the plugins, are most problems of openfire caused by its plugins?

tomlobato wrote:

Hi Antonio,

as you did also create a new database you could do a diff of both databases using Toad. I doubt that there is data in the old database which causes Openfire to behave in the way you’ve seen it.

Did you use the same plugin versions or did you install fresh versions? Maybe it was an out-dated plugin which did cause problems.

LG

Indeed, I agree. After reinstall and restore all users and rosters, I though it could be easer than that . I should first try to reinstall (and reconfigure) only openfire, not the db. I had upgraded openfire fom 3.5.2 to 3.6.2, keeping all configs and db. Surely next test/step would be keep db and reinstall fresh openfire. Sometimes under pressure I can`t think clearly.

I will try Toad as a post-morten check. In the new working system, I had to use archive version 1.0.5 intead 1.0.4. All other plugins are in the same version. It is the only different plugin version. It is curious, because as I can remenber, this openfire (+plugins) versions worked well for several months. I myself didn`t upgrade any plugin or made any change on openfire. I will ask the TI support people if it was changed something.

Hi LG,

today I had a problem with memory size of Java, because I forgot to copy this line to the new instalation:

INSTALL4J_ADD_VM_PARAMS="-Djava.net.preferIPv4Stack=true -Xms32m -Xmx800m"

ok, no problem, I copied and openfire worked again.

But it made me think about “Blank contact list” problem I had these days. I don`t know what is this -Xms32m, just copeied from from recomendations. Do you think my first problem could be because 32MB is too low, or any of this options is not good?

Hi Antonio,

-Xms32m is just the initial memory footprint of the JVM. The JVM allows that Openfire uses up to (-Xmx800m) 800 MB, so this is not a problem.

You could set Xms to 400 MB if your Openfire server needs nearly 800 MB.

LG

Had a very similar issue. Everyone was working correctly and then I started to try out some clients what had a smaller memory foot print then Spark has - I was never able to sign back into Spark again successfully and see my contacts. I wrestled with the issue for a week or so, but finally it appears I figured out that if I delete the user account of the person who does not see the contacts in Spark because they used a different client - then recreate it - they can sogn into Spark successfully again and see all their contacts. If I have the chance, I will test more with the theory that deleting the account and creating it again will work.

Hi gduquette,

thank you for the reply.

Tom