powered by Jive Software

BOSH timer in XIFF


#1

Hi

we encountered problems with xiff using bosh : too many requests generated problems … While setting a 100 or 200 value to the timer help…

Does anyone knows more about setting this value ?

Thanks !


#2

Is this the response timer in XMPPBOSHConnection.as? Can you post a patch for what changes you did?

Thanks,
Karthik


#3

hi Karthik,

I have similar problems, i think. I set the reponse timer to 100ms in XMPPBOSHConnection.as and my bosh connection seems to work better…I don’t understand why this timer was hide in the code (initialy on 0 ms …). In my case Bosh don’t support large amount of concurrent xmpp request, so i made others changes :

  • I set maxConcurrentRequests to 1

  • I limit the encapsulation of xmpp requests in an http request to one. The original code allow to put a max of 10 xmpp request in one httprequest. (hardcoded in the sendRequests function)

With this changes my bosh connection works but is very slow…Without this changes some requests like Vcard and room disco don’t return responses or in other case empty well formed responses ! strange but true…Have you any ideas about that ?

Thank’s,

Hadrien.


#4

Hadrien,

I think this is the most interesting problem in the library right now - a lot of people have reported having problems with overactivity. I will try to look into it more when I have time.

For now, if you are using OpenFire, you can set the ignoreOveractivity flag to true (see http://www.igniterealtime.org/community/message/188523#188523) until we get this fixed.

Setting max concurrent requests to 1 should help, but I don’t think you should have to lower the number of XMPP packets in an HTTP request. Does changing this value back to 10 still cause overactivity errors?

Thanks,

Karthik


#5

Karthik,

I’m using a ejabberd server side plateform and if i don’t make all the changes i told you, i get overactivity errors…If you have informations about this bug i will be very thankful.

Hadrien.


#6

Karthik,

Thank you so much for sharing this, it very much helped me resolve the same issue with BOSH. We are using EJabberD XML RPC.

I did not, however, need to set the max requests from 10 to 1, leaving them at 10 still worked just fine for our application.

I do now have a significant code base change from the 3.0.0 standard XIFF release, and would like to make a fork or possibly submit my changes to be considered for another release… 3.0.1?

Is XIFF dead? there haven’t been any new releases in years.


#7

Hi there,

Not dead, next release coming in couple of weeks.

Could you share the code and/or changes?