powered by Jive Software

Broadcast 1.6.0 and openfire 3.4.1

Hello!

After upgrade from openfire 3.3.3 to 3.4.1, broadcast plugin stopped working. On sending message to all@broadcast.xxx.xxx, in error.log i see:

org.jivesoftware.openfire.nio.ConnectionHandler.exceptionCaught(ConnectionHandle r.java:109)

java.lang.NoSuchMethodError: org.jivesoftware.openfire.SessionManager.broadcast(Lorg/xmpp/packet/Packet;)V

at org.jivesoftware.openfire.plugin.BroadcastPlugin.processMessage(BroadcastPlugin .java:197)

at org.jivesoftware.openfire.plugin.BroadcastPlugin.processPacket(BroadcastPlugin. java:155)

at org.jivesoftware.openfire.component.InternalComponentManager$RoutableComponent. process(InternalComponentManager.java:497)

at org.jivesoftware.openfire.spi.RoutingTableImpl.routePacket(RoutingTableImpl.jav a:234)

at org.jivesoftware.openfire.MessageRouter.route(MessageRouter.java:96)

What should i do to fix it?

Sorry for my poor english

Hello !

I have the same problem … broadcast stoped working.

Can anyone help ?

Hey guys,

A new version of the plugin that is compatible with 3.4 has been released. You can get the new plugin from here. Updating from the admin console may not work for this broken version.

Regards,

– Gato

Thank you, its working!

Thanks, its working, too!