powered by Jive Software

Broadcast chat message when users login

I have a strange problem here that I cannot seem to figure out. I am the administrator of an wildfire server that I recently upgraded to Openfire. Whenever my users login, they get a chat message from me, even when I am not logged in. I cannot seem to find the reason this message gets broadcasted to the users.

A second problem I am having is I have the Content filter plugin, E-mail listiener plugin and Packet filter plugin loaded that when I try to remove them they just pop back into the loaded plugin window.

Does anyone have any ideas?

Thanks

Just checking, any chance you have the motd plugin installed and that’s doing it? If someone receives a motd message and responds to it, it will likely come to you if you are the server administrator and might “feel like” it’s coming from you because of that.

The issue of openfire plugins not removing correctly is a known issue. for plugins with this issue you will need to stop the server, delete the jar file and the directory created by the plugin.

Now, my problem gets a little more complicated; can anyone help out, this has been drivng me crazy.

I do not have MOTD turned on.

We have a lot of users using JAJC, and a handful that use Pidgin. It seems that most (not all) of the Pidgin users also (which I previously was one) broadcast messages out to all users everytime they (The pidgin user) status changes. i.e Offline, online, away. The JAJC users pop up a blank message, where the pidgin users do not.

I would think that it is a problem with compatiblity of presence packets between the two client, but I didn’t have this problem previously on Wildfire, it only started when I upgraded to Openfire.

Any ideas?

Thanks

Oh, also it is worth noting that if I run a query on my Offline Message table, I can actually see the blank messages waiting to be delivered; so it may not simply be presence packets.

Presence packets don’t get stored in the offline table. The only thing that should be stored there are message packets. I’ve seen a number of clients not handle the type=“message” messages correctly, that might be what you are seeing. It would help to see the XML/XMPP traffic that is going between the server and the client.

Ok, after looking more into this thing for months. I actually appears to be tied to pubsub. Specifically the Tune portion that Pidgin uses. I have completely removed the entries from these tables:

pubsubAffiliation
pubsubDefaultConf
pubsubItem
pubsubNode
pubsubNodeGroups
pubsubNodeJIDs
pubsubSubscription

Without much difference.

I have also set xmpp.pubsub.enabled=false. All of this seeems to make no difference. We use JAJC as our perfered client (which also happens to be the only client with this problem)

Any ideas how to stop these popups?

It’s old discussion … but I found the same problem.

Problem is JAJC version 0.8.110 (maybe newer). Version 0.8.124 (or 125) is OK

Pidgin (miranda, jabbim) registers PubSub service - NodeID = http://jabber.org/protocol/tune and Jajc is unable work with it. Records from the database can notbe safely removed without restarting the openfire server.

Message from the server looks like this:

<message to="recipient@jabber.khnet.info/Resource" from="sender@jabber.khnet.info" id="sender@jabber.khnet.info__recipient@jabber.khnet.info__0yYmi">

 <event xmlns="http://jabber.org/protocol/pubsub#event">
  <items node="http://jabber.org/protocol/tune">
   <item id="pK28N9XoL0sRydO">
    <tune xmlns="http://jabber.org/protocol/tune"></tune>
   </item>
  </items>
 </event>

 <x xmlns="jabber:x:delay" stamp="2010-01-31T15:56:54.915Z"/>
 <addresses xmlns="http://jabber.org/protocol/address">
  <address type="replyto" jid="sender@jabber.khnet.info/jabbim"/>
 </addresses>

</message>

It should by able to prevent some clients pubsub service … but I don’t know how to do :frowning: