powered by Jive Software

Broadcast plugin lockdown isn''t working

I just upgraded to Wildfire 2.4.4 and got some users on and tried to lockdown the Broadcast plugin. So far though anyone seems able to broadcast, even when I set:

plugin.broadcast.disableGroupPermissions = false

plugin.broadcast.allowedUsers = me

Anyone know why that is, or ideas on how I could troubleshoot it?

Hi,

actually this should work, I just tried it. Maybe you did insert a trailing space in "plugin.broadcast.allowedUsers ", so it looks good but actually it isn’'t.

LG

PS: Bug Report and Feature Request:[/b] I use Firefox 1.5 and there the “Property Name” column is too small. I can only read “plugin.broadcast.allowedU”. And it is possible to add Property Names with trailing spaces, this is very confusing. Matt, please fix this.

PS: Bug Report and Feature Request:[/b] I use

Firefox 1.5 and there the “Property Name” column is

too small. I can only read

“plugin.broadcast.allowedU”.

I increased the size of the property name and decreased the size of the property value. So, should be a little less confusing.

-Matt

I just upgraded to Wildfire 2.4.4 and got some users

on and tried to lockdown the Broadcast plugin. So

far though anyone seems able to broadcast, even when

I set:

plugin.broadcast.disableGroupPermissions = false

plugin.broadcast.allowedUsers = me

Anyone know why that is, or ideas on how I could

troubleshoot it?

I’‘ve recently run into the same issue. I’‘ve triple-checked my property names to be sure I didn’‘t fat-finger anything and they’‘re correct. Just for good measure, here’'s what I set:

plugin.broadcast.disableGroupPermissions = false

plugin.broadcast.groupMembersAllowed = false

plugin.broadcast.allowedUsers = me

I’‘ve restarted the plugin and the Wildfire server application on the server and it’‘s still allowing broadcast messages from a test account I’'m checking settings from.

I’‘m running from LDAP (AD) and the Broadcast plugin version is the latest 1.3.1. I’'m just wondering if there is anyone else out there having a similar problem?

Jimmy

Hi Jimmy,

so you send messages to all@broadcast.domain and group@broadcast.domain or are you using the Spark feature “Broadcast message to Group”?

Your configuration looks fine.

LG

Hi Jimmy,

so you send messages to all@broadcast.domain and

group@broadcast.domain or are you using the Spark

feature “Broadcast message to Group”?

Your configuration looks fine.

LG

I’'m using the Spark feature “Broadcast message to Group.”

Any ideas?

Thanks!

Jimmy

Jimmy,

The Spark broadcast message feature doesn’'t use the plugin at all. Instead, it sends a message to each individual user in the roster.

Regards,

Matt

Jimmy,

The Spark broadcast message feature doesn’'t use the

plugin at all. Instead, it sends a message to each

individual user in the roster.

Regards,

Matt

So is there no way (short of a sparkplug) to disable this functionality?

Thanks!

Jimmy

This would be great if you could disable this server side so as not to leave it up to the users to add a certain plugin or not…

well, if you are planning to restrict users from broadcasting, so you must be able to lock down their clients and deploy all plugins automaticly. That’‘s form administrator’'s point of view. You cant disable it server side (well, in Spark case you probably could, because of integration of Spark and Wildfire), because clients are doing it by sending simple message to multiple receivers. You dont want to block them from chating