powered by Jive Software

Broadcast Plugin

Hi all !!!

This is my first instalation and use of openfire.

My environment

Windows 2003 R2 X64 Standar Edition

OpenFire 3.8.2

Today I installed the Openfire 3.8.2 and installed broadcast plugin from Available Plugins but in Server proprierties I can’t find where to set the properties listed in BroadCast Plugin Readme.

Does anybody knows ?

Overview

The broadcast plugin broadcasts messages to all users in the system or to specific groups. It’s primarily useful for sending announcements or notifications.

Installation

Copy broadcast.jar into the plugins directory of your Openfire installation. The plugin will then be automatically deployed. To upgrade to a new version, copy the new broadcast.jar file over the existing file.

Configuration

The broadcast plugin is configured via Openfire system properties. These can be configured under Server/Server Manager/System Properties:

  • plugin.broadcast.serviceName – the name of the broadcast service. If no value is set, the default is “broadcast”.
  • plugin.broadcast.disableGroupPermissions – true to allow any user to broadcast a message to a group. When false, only group members or administrators can broadcast messages to a group. The default value is false.
  • plugin.broadcast.groupMembersAllowed – true to also allow group members to send broadcast messages to groups they belong to. When false, only administrators can send broadcast messages to a group. The default value is true. Note that the property value of plugin.broadcast.disableGroupPermissions can effectively override this value by letting anyone send broadcast messages to groups.
  • plugin.broadcast.allowedUsers – the comma-delimitted list of users allowed to broadcast messages to all connected users at once. When this property isn’t set, anyone is allowed to broadcast messages to all users. Users should be specified by their bare JID (e.g. john@myserver.com)
  • plugin.broadcast.all2offline – true to deliver broadcast messages sent to all@[serviceName].[serverName] to online and offline users. When false or not set only online users get the messages as described below.
  • plugin.broadcast.messagePrefix – Add a prefix for all broadcast messages. Set this to “(broadcast)” to prepend "(broadcast) ".

Using the Plugin

To send a broadcast message, send a message to all@[serviceName].[serverName] or [group]@[serviceName].[serverName]. For example, if your server is called foo and the default service name is being used, a message to all@broadcast.foo would be broadcast to all users connected to the server. For the group staff, a message to staff@broadcast.foo would be sent to all users in the group staff that are currently online or offline.

Note: for maximum compatability between group implementations, it’s recommended that you use lower-case group names in conjunction with the broadcast plugin.

These can be configured under Server/Server Manager/System Properties:

Admin Console > Server tab > Server Manager sub-tab > System Properties menu. If there is no such property, you can create one and set the desired value.

Thanks for your answer, I’ve create one propiert but it does not appear for future queries.

Don’t know what you mean by “queries”. You go to System Properties and put say

plugin.broadcast.serviceName

into Property Name field at the bottom, you add say

BBC

into Property Value field

and press Save property

But how can I see the values set on each propriety ?

plugin.broadcast.disableGroupPermissions

plugin.broadcast.groupMembersAllowed

My System Propierty panel only shows :

admin.authorizedJIDs

gdb-srv-openfire@gmz3ap13,admin@gmz3ap13,paulo_roberto@gmz3ap13,greice_faustino@ gmz3ap13,olivia_sa@gmz3ap13

Clique para editar esta propriedade
Clique para apagar esta propriedade

broadcast.enabled

true

Clique para editar esta propriedade
Clique para apagar esta propriedade

clients.allowed

Spark,

Clique para editar esta propriedade
Clique para apagar esta propriedade

If you do what wroot said, it will automatically show up in the list of existing properties. Did you hit the Save Property button?

Those properties doesn’t have any value by default i think. So you have to create them and set some value to actually see them.

1 Like