powered by Jive Software

Bug in nightly? Cannot connect with Jitsi client

My setup:

Openfire nightly 2014-05-15 (I would like to test message carbons with the fix from CSH)

Jitsi 2.5.5218

Problem:

When connecting with Jitsi (both desktop client and mobile client) “nothing happens” in the client and the following error is show in the server error log:

2014.05.16 07:05:39 org.jivesoftware.openfire.nio.ConnectionHandler - Closing connection due to error while processing message: …xml… The feature requested is not implemented by the recipient or server and therefore cannot be processed. …xml…

Jitsi desktop and mobile clients have worked well in OP3.8.2, OF3.9.2 and OF3.9.3 (the versions we have been using).

Full server error log:

http://pastebin.com/CszNzneN

I’ve just tried nigthly 2014-05-29, the issue still persists. Anyone?

I am also not able to login even in OF 3.9.3 (using window jtsi desktop client). When I add account using bare jid (@), jtsi client displays error “connection failed for the following account…”, and when I add account using only username by setting advance options to connect then it shows infinite busy (animated connecting loader) icon in front of account name.

Help would be appreciated!!

Created OF-819

as CSH already said in the other thread, we are not sure if this bug always existed or if was introduced with a recent commit.

I think a quick fix would be simply to check that the IQ is of type set or get before it’s handed over to createResultIQ(). But this feels like a dirty patch without understanding nor fixing the actual issue, so it may be better to investigate a bit.

I’ve tested with Jitsi client and had no issues to connect and send messages to Spark.

But you are right, it is a little bit inconvenient to create the account in Jitsi. I’ve seen this infinite busy icon, too, but eventually it worked, after retrying. It might be the “Google” option in the connection settings, which I disabled.

Anyway, Ram’s problem is probably a Jitsi configuration/settings issue, unless you see the same OF logs.

Anders’ problem is still strange, I couldn’t reproduce it with the latest OF and Jitsi.

Strange, I’ve just tried again with nightly from 2014-05-29, same problem with jitsi/jitsi-mobile. Will try latest nightly later. About creating accounts, my setup is openfire accounts connected to AD through ldap, so no accounts creation needed.

Also, I’m not sure it’s related but the bin/openfire.sh in nightlies seems very different from 3.9.3 and I get one error when stating openfire:

openfire/bin/openfire.sh: 24: openfire/bin/openfire.sh: shopt: not found

It looks incompatible with bin/extra/openfired since it does not have start/stop-commands etc, not sure how exacly I’m suppose to set up the service now.

The server is running Ubuntu 12.04

(Edit: Nope, the same issue with 2014-06-04)

Message was edited by: Anders Sandblad

Can connect with Jitsi on latest Openfire build. Not using LDAP though.

We are not sure, why you experience this bug all of the sudden with 3.9.3. I also couldn’t reproduce it with Jitsi.

From looking at the code and at your stacktrace it seems, that your Jitsi client receives a ping from the server before you are authenticated. Why is still unclear to me.

Jitsi obviously does not support ping (XEP-199) and therefore returns an error, which is then cannot be handled and results in the error.

I’ve hopefully fixed it. Could you try a new nightly, when it’s available!?

I did not have a problem with 3.9.3, only nightlies. I should have tried nightlies before 3.9.3 but it seems like they have been removed now.

I will try your fix, I guess it’s not possible to know if it made it into the nightly on June 07, 2014 so I’ll have to wait for the nightly from June 08, 2014.

Thanks for your eager willingness to test nightlies! It’s very appreciated!

But this time I suggest, you wait a few more days.

I am currently working on a regression, which was introduced with the addition of Message Carbons (OF-818). Because code has to be touched, which also affects Message Carbons logic, it’s probably better to test if this is fixed, too. So we can be sure, that Message Carbons still work, after OF-818 has been fixed.

Ok!

I’m not sure what I did wrong previously but I’m currently running nightly 2014-06-23 and “everything” works:

  • Carbons works great, no issues for 48hrs. (it’s awesome, a must have for the mobile world of today)

  • Jitsi can login

  • I got init-script for debian working again

I also found the IM client Conversations for android and it’s the best XMPP-client so far! I can really recommend it. Like every other client out there some must-have features are missing: avatars from server and server side bookmarks support.

We’ll keep running this nightly until 3.10 is released and report any other issues found.

Anders Sandblad wrote:

Conversations for android and it’s the best XMPP-client so far!

The best paid app you meant? I think i’ll stick to Xabber.

Conversations is released under GPLv3 and available without charge from the f-droid repository: https://f-droid.org/repository/browse/?fdfilter=conversations&fdid=eu.siacs.conv ersations

Sadly the author decided to implement his own XMPP stack instead of using aSmack. This leads to some open security related issues like https://github.com/siacs/Conversations/issues/20 and some missing (important IMHO) implementations like https://github.com/siacs/Conversations/issues/170 and https://github.com/siacs/Conversations/issues/134

All of those are fixed in (a)Smack.

Xabber development has been mostly inactive since redsolution open sourced it. Which is sad, since they where contributed many changes and improvements back to (a)Smack.

I recommend yaxim for XMPP on Android (yaxim.org).

Yes indeed, i think i remember only one update of Xabber in a year or so. Thanks for a hint, yaxim looks limited in features (no multiple accounts, emoticons, etc.), but promising. Also it has Carbon Messages support, which is nice.

yaxim also has emoticons support

I am glad to read that my Message Carbons implementation works for you!

Also the recent fix in nightly, which caused your Jitsi login to fail.

Thanks for helping

I see that it supports emojis, but not the regular emoticons, it doesn’t convert : and ) to a smiley