powered by Jive Software

Bug in setup wizard

I’ve tested this in version 3.3.2 of the Mac OSX .dmg based installation, the tarball based linux/unix installation from Ignite Realtime, and in the portage ebuild based installation in Gentoo Linux. Same problem in all of them. While following the installation instructions found at http://www.igniterealtime.org/projects/openfire/documentation.jsp I get the following error after I click on the Continue button for the page in the setup wizard for creating an admin user:

java.lang.NullPointerException
     at org.jivesoftware.openfire.admin.setup.setup_002dfinished_jsp._jspService(setup_002dfinished_jsp.java:74)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
     at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:491)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1074)
     at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
     at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1065)
     at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1065)
     at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:41)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1065)
     at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1065)
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1065)
     at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:365)
     at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:185)
     at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
     at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:689)
     at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:391)
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:146)
     at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
     at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
     at org.mortbay.jetty.Server.handle(Server.java:285)
     at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:457)
     at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:751)
     at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:500)
     at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:209)
     at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:357)
     at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:329)
     at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:475)

Yes! I got similar errors about jsp files for the admin concole after trying to use a version compiled from SVN. Using jdk 1.6.0_02 and ant 1.7.0.

I downloaded the zip of the latest binary distribution and copied the admin plugin except the lib directory (actaully copied the lib directory from my compliation after it still didn’t want to work).

Does the SVN ever give you a usable distribution? I’m also missing the openfire-service.exe for windows…