powered by Jive Software

Bug when making Custom Database Integration

I did everything as described in http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/db-integ ration-guide.html and the integration with my custom database (postgresql) didn’t work.

When I looked in the logs, it was saying that the configurations in the XML file was different of the database configuration. Then, I had to change the configuration of the auth provider and user provider classnames in the database and it worked.

But then the configurations in the XML files are erased and it is now like this:

I think this is a strange behavior.

The integration is working fine, but I think it should have worked immediately when i set up this in the XML file, as described in the documentation.

I dont think this is the proper location for this post. This might not be a feature request more of a plugin…

I have tried setting up to access, users and group from the SMF database, but it seems the config changes force the app to go through the setup again resulting back to the deafult config i had before modification. I have checked the error logs and have not found anything to be causing the reset. I have also created a post in the SMF forums concerning integration for those who may be interested in following this. just search for my username.

Here are the resources I have been through with no luck.

I am looking for/requesting the ability to integrate openfire+spark jabber services into SMF. I have found vbulletin plugins here:

http://www.vbulletin.org/forum/showthread.php?t=191448

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/db-integ ration-guide.html

http://www.igniterealtime.org/community/message/146754#146754

Any response would be appreciated.