powered by Jive Software

Cache Roster was full, shrinked to 90% in 0ms


#1

Can anybody help me clean this up? Showing up in my log warnings:

2013.04.05 09:46:35 org.jivesoftware.util.cache.DefaultCache - Cache Roster was full, shrinked to 90% in 0ms.

2013.04.05 09:47:15 org.jivesoftware.util.cache.DefaultCache - Cache Roster was full, shrinked to 90% in 0ms.

2013.04.05 09:48:22 org.jivesoftware.util.cache.DefaultCache - Cache Roster was full, shrinked to 90% in 0ms.

2013.04.05 09:49:06 org.jivesoftware.util.cache.DefaultCache - Cache Roster was full, shrinked to 90% in 0ms.

I’m using OpenFire 3.8.1. The roster is generated by being a member of an AD group. I know all my ldap settings are fine and these warnings don’t seem to be affecting anything.


#2

I have cache.username2roster.size set to 10485760 - Could try to set that and cycle OF and see if it clears up the warning.


#3

The cache is too small, increase it as David did suggest.

With a too small cache Openfire needs to make a lot of database queries which may result in high CPU usage of the database server and slow performance of Openfire. Shrinking the cache also takes some time, so it should be avoided.


#4

yep, I’ve met the same issue. Believe it can work as normal, thanks for above all.:smiley:


#5

I have done all these things but issue is not resolved.