powered by Jive Software

Call by Phono

Hi,

Thank you for creating such a nice module.

I am really excited to use it.

I am still new to Openfire and have problems with Redfire.

I installed Redfire 0.0.3.2 to my server that has a public IP address.

Openfire’s version is 3.8.1 and the OS I am using is FreeBSD 9.1R.

The access to http://myserver:7070/redfire is successful and ‘Chat’ with a specified XMPP account on a Phono session works well too.

2Way audio/video, 4 persion audio/video conference also work well.

However, ‘Call’ another Phono session and a sip account on localhost + asterisk does not work.

There is no error message in error.log (actually it’s empty).

Maybe I miss some settings for sip or something, but could somebody give me a hint on it?

If voice conferencing is easily possible on a browser, I will do a lot of work with it.

So, I am really excited.

Thanks!

I could solve by myself…

Actually, Phono sessions on the same browser seem to be unable to call each other, so it’s OK.

Phono sessions on different computers worked well.

Also, Asterisk on the same server as Openfire seems to be problematic, so I installed Asterisk on another server.

The problem was Phono <-> a sip client like linphone.

OK, I used 101@sipserver.com to login from linphone, and Redfire also uses sipserver.com as voicebridge.default.proxy.name and the SIP server.

I don’t know why but calling 101@sipserver.com from Phono fails.

However, calling 101 (no domain name) worked well.

So, I needed to remove the domain name…

Linphone to Phono was OK with a regular address like sip:3e9rw4@openfireserver.com.

I couldn’t try conferencing on Openfire, but could voice conference with Asterisk’s ConfBridge.