powered by Jive Software

Caller ID Screen Pop works w/ Trillian, not w/Spark

I have Wildfire set up and working properly except for one little detail. The screen pops for incoming calls don’'t display the Caller ID. It merely says, “Your Phone is Ringing” in the popup dialog, no Caller ID. Is this by design? Is there a way to configure spark to add the Caller ID info in the dialog?

Trillian does show the CallerID just fine.

(Should I post this in the forums for Spark?)

Using:

Wildfire 2.4.3 and Spark 1.0.4 and Trillian 3.1 b121 and Asterisk-IM 1.0

Hi,

for asterisk this is the right forum. Using Spark you have the option to show all packets (Menu Help, Show Traffic Window). Is the number in the xmpp packet which causes the “Your Phone is Ringing” popup?

Either it is, then it becomes a Spark issue or the asterisk-im plug-in has a problem. I think the Spark developers also look in this forum, and one has always the option to send a PM.

LG

After looking through the packet traffic window, I think that this is by design in Spark (or Smack). The proper events and the Caller ID are being passed, but the notification dialog is just not programmed to show the Caller ID. So I want to make this a feature request. While I’'m on the subject of this notification dialog box, I would like to make a couple more requests for Spark.

First, a way to disable the “On The Phone” dialog that shows up (when you pick up on a call) and counts the seconds that you are on the phone. It’'s pretty redundant when your phone already has a call timer.

Second, try to move the notification dialogs to a system tray balloon on Windows. Just like Trillian does it.

Hopefully someone in on Spark development will see this.

post these requests in Spark forum

[/nobr]Hi wroot,

posting everything two or more times is for the ones who read the forum not really nice. A private message to a (Matt, Gato, Derek, …) should do it, so one is also quite sure to get a reply.

LG[nobr][/nobr]