Can OpenFire support Sql Server 2008 Express R2?

I have tried to make sql server 2008 express r2 as the external database for Openfire server?

but when I configure the connection in the wizzard,it always report can not connect to the database server,

I 'm very sure the user name and password and the option driver class I have select the correct one (like the document said),and

the database is available for connection.

So can you help to identify what’s the issue?


Try making your serverURL similar to this; SQLExpress uses “instances” (I think so it can be installed with standalone apps).

jdbc:jtds:sqlserver://SERVER/openfire;appName=jive;instance=SQLExpres s

You are Great ,Michael !

It works like a magic!

1 Like

This solution didn’t work for me, unfortunately. This is a Windows Server 2008 R2 with SQLExpress R2 installed. It is not a domain and not joined to a domain. In fact, it’s a Hyper-V virtual machine to be precise.

I’ve tried using the direct IP address, localhost, instance=SQLEXPRESS at the end, nothing works. I’m going to attach my error log. Maybe someone can shed some light on this? I am also using the default Sql account sa. (1427 Bytes)

you have to set your sql instance port from dynamic to something static. If its the only instance on the server, than you can use the default port of 1433. If its not the only sql instance, than you may want to use something else, like 2433.

then your connector setting should go like this. notice the (:slight_smile: after the port number!! very important!


heres mine


This is the only instance on this server. Now, as I was looking at the IP’s through the SQL Configuration Manager, It lists IP’s from IP1 through IPall. Which IP needs to be static?

One other thing, I also noticed that for each IP, there set to Active=Yes, but Enabled=No. And the TCP/IP Properties status is Disabled. Does any of this also have to be changed?

yes…enable tcp/ip protocols for your instance, (you’ll have to restart your services after making this change) then make sure your tcp port is 1433 in all the fields.

I enabled everything. The tcp/ip protocols, all IPx’s are Active and Enabled, every IPx has the TCP Dynamic Ports “0” removed and every IPx TCP Port has been set to 1433, SQL Server service has been restarted and still cannot connect to the database. Here is my error log again. I am at a loss. I’m starting to think about dropping this and go with a different product. Everyone said this was a easy install. Now, I’ve wasted half my day yesterday and now almost all my morning. Here is my configuration:

Database Driver Presets: Microsoft SQLServer

JDBC Driver Class: net.sourceforge.jtds.jdbc.Driver

(This one, I have tried many different configurations) Database URL:



jdbc:jtds:sqlserver://name of server here:1433:/sqlexpress;appName=openfire_server

Username: sa

Password:XXXXXXXXXX (1892 Bytes)