powered by Jive Software

Can´t find the gateway tab when trying to install Kraken OS X 10.6.2

For whatever reason (I have been considering taking some days off and going to spend them on the looney bin) I have “lost” the gateway tab.

I erased the old IM gateway settings for Yahoo and MSN

I was having problems with the Yahoo transport so I erased the opefire server and started from scratch.

I installed the Kraken Plug and when I went to the main menu to defined the gateways for MSN and Yahoo, it is simply no there.

I might have done something wrong in the installation process or I am just not seeing the whole picture, who knows everything is possible, I can only see 3 tabs (Server manager, server settings, media services) this is what I have on my installation notes, instead of the IM Gataway plug in I downloaded Kraken 1.1.3 beta and uploadedit.

A summary of the steps I used:

  1. Download and install OpenFire; make sure you use an embedded database when asked.
  2. Add a user to the system. Use a simple name, e.g. mark.
  3. Go to the Admin page, select Plug-ins, and install the IM Gateway plug-in. (In the Plug-ins tab, there is an available Plug-ins tab, which auto-downloads and installs!)
  4. On the Main menu, select Gateway -> Settings, and enable Yahoo/MSN and others you need. (This also allows you to test.)
  5. Register your user with the gateway. (i.e. associate your Jabber ID with your MSN user ID.) This can be done by either using the Gateway » Registrations tab, or by using psi or other similar Jabber client.
  6. In iChat, add a Jabber account, using username@hostname.local, i.e. mark@technobear.local. Note that you need the full name here, unlike in OpenFire.

http://www.macosxhints.com/article.php?story=20071030041941679

This is the procedure I folled to delete the openfire files and folders maybe it is something I did not erase.

First, make sure openfire is shut down. Then from the command line, you can just do:

sudo rm -rf /Library/PreferencePanes/Openfire.prefPane

sudo rm -rf /usr/local/openfire

sudo rm -rf /Library/LaunchDaemons/org.jivesoftware.openfire.plist

sudo rm -rf /usr/local/openfire

And that should get rid of everything.

Or maybe the installation procedures changes when using the Kraken PlugIn and I am not aware? Tried going back to the IM gateway (at least MSN worked) but it is no longer available.

Thanks in advance for help,

All most going crazy or just to dam tired :slight_smile:

Support for kraken should be sought at the developers page.

Thanks for your reply. I understand your point of view concerning the plugin (Kraken). That does not alter the fact that Openfire’s gateway tab cannot be seen.

Is there a reason for this? Is it a configuration problem? Or is it an issue that Kraken plugin and maybe any other “external” plugin must activate “something” in order for it to work with the Openfire application?

When the old definitions from IM gateway where still installed I could use the kraken plug in and had access to the missing tab. What has happened when I went and erased all files? Am I making an incorrect installation/ deletion? Maybe it is an issue that Openfire will not support Kraken.

I would love to understand and maybe stop loosing my time trying to make something work that is not meant to be or maybe look for another alternative that will render the same functionality that I had achieved using Openfire.

regards

kraken works fine with openfire. most likely you did something wrong. the tab comes from kraken, so once again please use their forums for support.

Thank you for your reply. I was able to finally install the gateway. It seems that the problem was the name of the kraken file. Since I had downloaded a previous version, the new one was renamed and for some reason this generated installation errors.

I erased all files (openfire included), renamed the pluign and installed it. Now I am able to see the gateway tab.