powered by Jive Software

Cannot access admin console

I had ubuntu 8.04 running openfire just fine and decided to upgrade to 9.04. I ran into a snag and ended up removing openfire and attempted to reinstall it. All goes fine until the login stage and it tells me my password is invalid. I have uninstalled and reinstalled repeatedly also used the .deb file and tar file multiple times, same result. If I try and restart openfire once installed, I get this error:

HTTP ERROR: 404
NOT_FOUND
RequestURI=/
Powered by jetty://

I have tried restarting the server and openfire multiple times, it is the same thing.

Checking the error log, it says this:

2009.06.29 11:46:52 [org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlugin.java:142)] Could not start admin conosle server
java.net.BindException: Address already in use
        at sun.nio.ch.Net.bind(Native Method)
        at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:119)
        at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
        at org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:205)
        at org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:304)
        at org.mortbay.jetty.security.SslSelectChannelConnector.doStart(SslSelectChannelConnector.java:566)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)
        at org.mortbay.jetty.Server.doStart(Server.java:233)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)
        at org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlugin.java:139)
        at org.jivesoftware.openfire.container.AdminConsolePlugin.initializePlugin(AdminConsolePlugin.java:174)
        at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:448)
        at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java:47)
        at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManager.java:1032)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)

However I have checked the ports and nothing else is using 9090. It seems like openfire is actually running correctly at this point, but I have no way to get to the admin console. I have even tried using mysql as well as embedding the database and It always says I have the wrong password after installation, even though the database is populated correctly. Once I try and restart either openfire or the server I get the errors above.

I am wondering if this is due to something that changed in my apache or ubuntu installation, but I can’t pinpoint the source of the error. Hopefully someone more experienced can tell me what is wrong.

bump. I know other people have had similar errors, just none of the solutions have worked with my installation, but I am willing to try anything new.

2009.06.29 11:46:52 [org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlugin.java:142)] Could not start admin conosle server
java.net.BindException: Address already in use

Looking at your log output, it seems that the server is still running when you are trying to
shut it down with the init script.

I had a similer condition the other day but not with admin login issue though.

If you are in any unix/linux platform, try followings:

netstat -an |grep 5222 to see if openfire is listenting on this port (5222 is the default openfire CM port)

Also try

ps auxwwww |grep openfire - get the PID of the openfire process.
kill -9 "openfire_PID"

Now Try to start it with service openfire start command and try to login to your admin account from the web console.

Two things you have to keep in mind -

- Your database server is working properly
- connectivity to active directory/LDAP is good. (if you are using LDAP)

Good luck.