Cannot checkout Spark client

Hi, I am trying to check out spark source with this:

svn co spark

However I am always getting this:

svn: REPORT of ‘/svn/repos/!svn/vcc/default’: Could not read response body: connection was closed by server (

And if I try to check out withing eclipse, after some time downloading some files and directory on the build directory, it fails subsequently:

svn: Processing REPORT request response failed: XML document structures must start and end within the same entity. (/svn/repos/!svn/vcc/default)

svn: REPORT request failed on ‘/svn/repos/!svn/vcc/default’

Is there any other mirror to check out from, or perhaps a zip file of the source for Spark?


Anybody home? Same problem here…

I have checked yesterday and i was able to sync my existing svn version. I’m using RapidSVN, but i’m also able to browse svn with the Fisheye. What tool are you using?

I am using TortoiseSVN. I am attempting to do this for the first time. There must be a difference between “new” and “update”.

Are you able do a new sync?

I’ve got the same error with Tortoise SVN when doing a fresh Checkout and also it freezed at some point. Every time i just did the SVN Update afterwards and it keeps updating. Probably this is somehow related how igniterealtime server is configured. It doesn’t support download resume and maybe has some other limitations, e.g. nightly builds dowloads often break so you have to redownload it again. I have already complained about this in the forums, but that’s the only thing we can do. Jive Software runs this server (for free).

UPD: after 3 SVN Updates it has eventually completed the checkout, i think.

Not that I know what to do with it if it works, but are saying that if I run it a few times it might resolve successfully? Eventually?


When it shows you that error, close Tortoise window, right click the folder with the source and choose SVN Update. Repeat this if you get another error or if it gets stuck. Until you see “Completed”. To check if it has downloaded the whole source you will have to compile this thing

please try again!