powered by Jive Software

Cannot connect to admin console

I just installed OpenFire on my MacPro running Leopard. The server claims to be started, but I cannot connect to the Admin Console in System Prerences. I tried

http://127.0.0.1:9090 manually, but that did not connect either. I see nothing in the firewall logs.

So how do I administer the server?

Hi James,

I guess that also on MacPro Openfire writes log files, maybe you can take a look at them and verify whether Openfire opens port 9090 or not. info.log should contain a line with “Admin console listening at: http://hostname:9090/

LG

2007.11.16 15:49:33 Admin console listening at http://127.0.0.1:9090

But it does not answer

The error log is empty.

Hi James,

are the server and your browser are on the same computer?

Do you have something like a “shell” on Mac where you can enter “netstat -an | grep 9090” to verify that port 9090 is open?

LG

It’s possible that there is a bug in the installer when running on Leopard. I have tested upgrade installs thoroughly, but only did cursory initial installation testing. I’ll try to get to that soon and let you know what I find.

It seems to be listening:

sh-3.2# netstat -an | grep 9090

tcp4 0 0 127.0.0.1.9090 127.0.0.1.54750 ESTABLISHED

tcp4 0 0 127.0.0.1.54750 127.0.0.1.9090 ESTABLISHED

tcp46 0 0 *.9090 . LISTEN

tcp4 0 0 *.9090 . LISTEN

c58bc38 stream 0 0 0 c690908 0 0 /var/run/mDNSResponder

c690908 stream 0 0 0 c58bc38 0 0

Thanks. It could be the new Leopard application firewall too. It is impossible to set it for a new system service. But there is nothing in the firewall logs.

I can connect to my slimserver on 9000 though, but since it is a .app, I can put it into the firewall.

I tried connecting from another PC to it, and got

Nov 16 17:36:15 jarmac Firewall[56]: Allow perl connecting from 192.168.1.49:1195 uid = 0 proto=6

Is this app written in perl? But still does not connect. I think the server must be screwed up.

Its not the firewall because the above tcp test worked.

Hi James,

it looks like you are connected with your browser.

tcp4 0 0 127.0.0.1.9090 127.0.0.1.54750 ESTABLISHED

tcp4 0 0 127.0.0.1.54750 127.0.0.1.9090 ESTABLISHED

So I wonder if Openfire has a bug and does not send any data to the browser.

You could try again in the shell:

telnet 127.0.0.1 9090

and then enter completely blind:

GET /login.jsp HTTP/1.0

press enter a few times and wait for a response. If a lot of HTML code is displayed then it could be a problem with your browser.

LG

Its the app:

sh-3.2# telnet 127.0.0.1 9090

Trying 127.0.0.1…

Connected to ad.doubleclick.net.

Escape character is ‘^]’.

GET /login.jsp HTTP/1.0

GET %2Flogin.jsp HTTP%2F1.0

and that is all it writes out

(I have ad.doubleclick.net routed to localhost to stop any connections to it, but that should not affect this since localhost:9000 works)

Hi James,

I hope that David brings up some more details, for me this looks like an “echo service” and not like Openfire responding. You could also try to connect to your network IP (192.168.1.1 or something like this) with http://192.168.1.1:9090/ - but you may get the same result as on localhost.

LG

Same none response with the ip number.

Hmmm. I turned OpenFire off, and get the same response to Telnet. How can this be?

How do I uninstall OpenFire, by the way. If we cannot figure this out, it is doing me no good.

Thanks,

Jim

Hi Jim,

are you sure that Openfire is really stopped, or is it possible that you have inetd running?

Did you try https://127.0.0.1:9091/ ? Can you try to connect to any other port (like 12345)? If you do not get a response there then you may want to edit conf/openfire.xml and adjust the port to one which is not used.

LG

I stopped it using the Mac System Preferences for OpenFire. It would be good for users if you told people where OpenFire was installed. I was not able to find it easily.

Switching it to 9099 worked! Maybe Leopard has something else running on 9090?

Hi Jim,

I don’t know much about Mac shell. As root, can you do something like the following?

sh-3.2# lsof -i :9090

In Linux that shows who owns the listening port. If it’s Openfire application, it should show something like:

COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME

java 24381 daemon 46u IPv6 89917 TCP *:9090(LISTEN)

Otherwise, it could be some other application.

So now the server is running, but I get errors. In the warning log, I get:

2007.11.17 10:18:46 Error when trying to update to new name

java.sql.SQLException: Table not found in statement

at org.hsqldb.jdbc.Util.throwError(Unknown Source)

at org.hsqldb.jdbc.jdbcPreparedStatement.<init>(Unknown Source)

at org.hsqldb.jdbc.jdbcConnection.prepareStatement(Unknown Source)at org.jivesoftware.database.AbstractConnection.prepareStatement(AbstractConnectio n.java:36)at org.jivesoftware.database.SchemaManager.updateToOpenfire(SchemaManager.java:298 )at org.jivesoftware.database.SchemaManager.checkOpenfireSchema(SchemaManager.java: 66)at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:467)at

org.jivesoftware.openfire.admin.setup.setup_002ddatasource_002dse ttings_jsp._jspService(setup_002ddatasource_002dsettings_jsp.java:155)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:712)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:211)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:313)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)

at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:830)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442) 2007.11.17 10:20:32 Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.2007.11.17 10:20:32 Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.

I also get errors:

2007.11.17 10:57:35

org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSessi on(LocalOutgoingServerSession.java:258)

Error trying to connect to remote server: conference.jarmoc.local(DNS

lookup: conference.jarmoc.local:5269)

java.net.UnknownHostException: conference.jarmoc.local

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:432)

at java.net.Socket.connect(Socket.java:520)at org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSess ion(LocalOutgoingServerSession.java:253)at org.jivesoftware.openfire.session.LocalOutgoingServerSession.authenticateDomain (LocalOutgoingServerSession.java:143)at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:205)at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:185)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 650)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)

at java.lang.Thread.run(Thread.java:613)2007.11.17 10:57:35

org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSessi on(LocalOutgoingServerSession.java:258)

Error trying to connect to remote server: jarmoc.local(DNS lookup:

jarmoc.local:5269)

java.net.UnknownHostException: jarmoc.local

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:432)

at java.net.Socket.connect(Socket.java:520)

jarmac.local is defined in /etc/hosts:

127.0.0.1 localhost jarmac.local

Hi,

I assume that you did a fresh installation and that the warning “Error when trying to update to new name” did occur exactly one time. Or did you connect this server to an existing, old Wildfire or Openfire database?

You may want to add conference.jarmoc.local to your /etc/hosts file if you want to manage s2s via the /etc/hosts file. An alternative and maybe better solution is to handle this within Openfire by setting a “System Property”, see http://www.igniterealtime.org/community/docs/DOC-1061#dnsutil.dnsOverride

LG

Thanks everyone for the help. It would be good to know what else runs on 9090 on a Mac. Switching the port to 9099 fixed it.