powered by Jive Software

Cannot connect to http://myserversip:9090

I’ve been googling around on this issue for awhile and I can’t seem to find a way to get this to work.

I am running Centos 6.5, and have installed the .rpm package via wget. The CentOS 6.5 version I am running is 64 bit and I believe that’s one of the first issues I am running into. I found that it may requier a certain file to work called libldb.i686 so I did a “yum install libldb.i686” and selected yes for all the packages it ran.

I had to do this because before installing this file the service would not run, even though in “setup” it would say it was running, but if I did a “service openfire status” or stop or start it would say its starting but wouldn’t show anything, and if I did a status or stop it would say it wasn’t running. After installing the file and a server restart it says the service is running.

However, now my problem is that I cannot connnect to http://myserversip:9090 to continue the setup process. The connection attempt times out. I’ve tried 9091 as well. I’ve seem to have hit a brick wall.

Can anyone out there please point me in the right direction when it comes to get the ability to connect to the admin site whatsoever. I haven’t even gotten as far as getting a login page…

I’ve heard that it may be needed to install the .tar.gz file rather than the rpm, which is odd because igniterealtime.org suggests to use the rpm.

Has anyone with a similar setup run into this? How can I overcome this. Please help!

There are two possible things that could be interfering from what I can see.

If you are confident that openfire is starting and running in the background (~]# service openfire status), then:

First, make sure your firewall (iptables) is not blocking you.

~]# service iptables status

See if it’s blocking stuff. If you are unsure, you can try temporarily disabling iptables and see if it resolves your problem. I would not leave iptables off. If this is your problem, you will need to create the proper rules to allow the correct openfire ports access

~]# service iptables save

~]# service iptables stop

Now test and see.

SELinux could also be messing with you… but first try the firewall.

Jason,

Thanks for your help. I got it up and running shortly after this post, but you were right, it was a combination of SELinux and default iptables. I forgot my basics when installing the server :\ SO anyone who stumbles across this, make sure you disable your firewall and SELinux to test it, THEN lock things down from there.

Thank you for your help.