powered by Jive Software

Cannot connect to MySQL Database

Hi,

I am new with the Openfire, Please help my problem regarding on how I can connect to MySQL database. I am using Widows 7 (OS), I already made a database named “openfire” and no password. My MYSQL version is 5.5.8. When I setup openfire installation, I choose “Extended Database Connection” and I input the following:

Database Driver Presets: MySQL

JDBC Driver Class: com.mysql.jdbc.Driver

Database URL: jdbc:mysql://localhost:3306/openfire

Username:

Password:

Minimum Connections: 5

Maximum Connections: 25

Connection Timeout: 1.0 Days

Still not connected and I cannot proceed to the next step of installation due to this error. I attached herewith the error I encountered during installation.

This error are from MySQL logs

**-----------------------------------------------------------------------------
**

120724 12:13:56 [Note] Plugin ‘FEDERATED’ is disabled.

InnoDB: The InnoDB memory heap is disabled

InnoDB: Mutexes and rw_locks use Windows interlocked functions

InnoDB: Compressed tables use zlib 1.2.3

120724 12:13:56 InnoDB: Initializing buffer pool, size = 128.0M

120724 12:13:56 InnoDB: Completed initialization of buffer pool

120724 12:13:56 InnoDB: highest supported file format is Barracuda.

120724 12:13:56 InnoDB: 1.1.4 started; log sequence number 1896233

120724 12:13:56 [Note] Event Scheduler: Loaded 0 events

120724 12:13:56 [Note] wampmysqld: ready for connections.

Version: ‘5.5.8-log’ socket: ‘’ port: 3306 MySQL Community Server (GPL)


Please HELP…

Thanks.

check that windows firewall don’t block your mysql connections and you must create login and passwd for user to connect to mysql. be shure that user you are create have acceess to openfire db

Thanks Mr. Nail

But I already Turn Off my Firewall and still I cannot connect to my database named “openfire”…

How about to create user to access DB?

Why should I create a user to access a database?, I am on the installation step in setting up a database to connect on my created database named “openfire”…

Thanks.

MySQL installation don’t allow anonymous connections

I tried to make a user to access DB, but still it does not work…

Thanks.

Thanks for the info, and I already connect to the database…

Bravo! for all the helpful tips…