Cannot connect to openfire after Lollipop upgrade

Hey guys hope someone can point me in the right direction or shed some light on this. Our company uses Samsung Note 3s and a couple of 4s for the guys in the field. I have Openfire running but the problem is, if the phones are upgraded to Lollipop, they can no longer connect to the OpenFire server… it just sits there at connecting. I’ve tried many clients (Xabber being the main one we use) and the results are the same.

I’ve tried every possible combination in the settings of the client but it will not connect. Has anyone ran into this issue?

Thanks guys

It must be some Samsung stuff. My Nexus 7 has no problems connecting to Openfire with Xabber or Yaxim. Already on Lollipop 5.1. Was the same with 5.0.2.

That was my worry wr00t, thanks for the reply. If you hear of a workaround it’d be much appreciated !

Just a heads up I found the culprit. My server was running Java version 1.6 which in turn made my Samsung devices refuse to connect. As soon as I upgraded to 1.7, all is well again.