Cannot connect to server


New installation of openfire on a new server

I have opened firewall on server and client yet I cannot log in. Either I get cannot find server after authenticating is displayed for a few minutes (when server is simply server name or the ip address), or if I change the server address to http://server:9090, then I instantly get the message Invalid username or password.


Thanks a billion!

p.s. Before upgrading our server, we used wildfire for years without issue!

You shouldn’t put that URL as a server. What exactly have you opened on the server? You should open 5222 port (or try with firewall disabled first). Also first try with IP and when it works, then try with server’s name.

1 Like

Thanks so much for your response.

I’ve tried all that and nothing has worked.

I assume usernames are just usernames as they are in the system, although with wildfire I had to type USERNAME@server, but this doesn’t work here either!

I don’t remember it ever needing username@servername. That’s why Spark has a separate field for Server. Don’t know why it doesn’t work for you.

There are a couple of things that you should verify:

  1. Is Openfire up and running? On the server on which Openfire is installed, open the Admin Console in your browser ( http://localhost:9090 ) and see if you see a login page.
  2. If you do (assuming that you are an administrator), log in with your admin credentials. When your network configuration allows this, you can also open the Admin Console from another computer. In that case, replace the ‘localhost’ in the URL above with the network address of the server on which Openfire is installed.
  3. The first page of the Admin Console (after you log in) lists the “Server Name”. This is the name of the XMPP domain that is realized by your Openfire. It can, but does not need to be the same as the hostname of the server that is running Openfire. The XMPP domain name is part of the identification of the users (not the hostname).
  4. In the Admin console, open the “Users/Groups” tab and see if the users that you expect to be in the system are actually there.

If the above checks out, you should be able to connect to Openfire with any XMPP client (network configuration permitting). When your server name differs from your XMPP domain name, make sure that you use the XMPP domain name as part of your login. If the XMPP domain name does not resolve to the server name (via DNS), most clients will allow you to manually define what ‘connect host’ to use for your login. How this is done differs for each client. Typically, you’ll need to open some ‘advanced configuration’ type of setting dialog.

1 Like

Thank you so much!

Once I changed to the correct port (5222) it works!