powered by Jive Software

Cannot launch Spark on Mac OS X 10.8 Mountain Lion

After installing Spark 2.6.3 I get an error when I try to launch the app saying that it is damaged. I think this is the firest time I’ve used it since installing OS X 10.8 Mountain Lion. Is there a new version of Spark coming?

we are looking forward to release spark 2.7.0. Hopefully with osx 10.8 support. maybe i could have a closer look to the problems you are reporting later this day

I tried to launch spark 2.6.3 in on my macbook (Mac OS 10.8.1) and it works as intended. I used the version which can be found on the download page, as well as the version from the continuous integration. Both run smoothly but i would recommend to use the CI version.

You can change your security settings to allow spark to run. Follow the instructions here: http://support.apple.com/kb/PH11439

1 Like

oh yes, that might fix the problem. Deactivating this “security” feature was the first thing i did after installing the mountain lion.

it should be disabled by default until we don’t want to pay 10000$ per year to be an “identified developer”

Yes, this works, thanks. However, when you try to perform a one-time bypass of gatekeeper (such as right-clicking and clicking “open”) on Spark it doesn’t work, and reports the app as damaged, so it’s not clear to users that this is a gatekeeper issue and that you guys aren’t just shipping broken code.