powered by Jive Software

Cannot login to fresh OpenFire install

Hi,

I’ve just installed OpenFire 3.6.4-1 on a basic CentOS 5 install (not sure which version, I’ll ask), with MySQL 5.0.77-4 as the database workhorse. I can get through the installation and setup process just fine, but when it comes time to log into the admin panel nothing works. I’ve tried a blank password, the password I previously set the account to (to no avail), and I’ve even reset the plain-text password to “123456” in the database—and still I cannot login. I get “Login failed: make sure your username and password are correct and that you’re an admin or moderator.” every time I attempt to log in.

The logs show nothing helpful. I’ve checked the tables ofUserFlag and ofUserProp and ofGroupUser, and they’ve no entries (presumably I lack admin rights). But I have no notion of how to proceed.

Any help is appreciated!

  • Robert

I experienced the same thing just today. Unpacked the tar.gz file for openfire 3.6.4 and replaced the /opt/openfire directory with the new one. Followed the instructions on http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/upgrade- guide.html. After that, I got a permission denied message when i tried to restart openfire by /etc/init.d/openfire start. Would really appreciate some help here. Thanx

Doyin

I just figured out how to solve this issue: reload the openfire service. It’s rather inane that this must be done, but on CentOS it’s “service openfire reload”. See this post for who I got it from.

Just tried that and i still get the same message when i restart- “Starting openfire: sh: /opt/openfire/logs/nohup.out: Permission denied” What’s that about pls

just discovered i can only access the openfire web gui when i run /opt/openfire/bin/openfire.sh and get the output Admin console listening at 127.0.0.1:9090

What distro of linux are you using? I’m on CentOS, so I’m using commands for RedHat or CentOS … I don’t necessarily know them for your distro.

Try running the following command and telling me what it says:

 sudo service openfire status

If it says “stopped” or something similar, run this:

 sudo service openfire start

If it says “started”, try:

 sudo service openfire reload

restarting the service worked for me too.

I use CentOS also. I’m just gonna re-install and setup again. Try the openfire upgrade from scratch