powered by Jive Software

Cannot start admin console

I have the oddest thing happening. I want to upgrade from wildfire to openfire. I use an external mysql database. When i start a fresh copy of openfire i can access the admin console and set it up (using the same DB as the old wildfire install) If i stop the service for any reason and restart it i can’'t access the admin console. I can still log into the server with a jabber client though. If i stop the openfire daemon and restart the old wildfire daemon everything works again. It says something is already using the port but nothing is running that could. If i delete the openfire folder, unzip the .gz again, and start it the admin console works again till i stop and start the service again.

here’'s a snippit of the error.log:

2007.07.14 11:47:19 [org.jivesoftware.openfire.container.AdminConsolePlugin.star

tup(AdminConsolePlugin.java:143)] Could not start admin conosle server

java.net.BindException: Address already in use

at java.net.PlainSocketImpl.socketBind(Native Method)

at java.net.PlainSocketImpl.bind(Unknown Source)

at java.net.ServerSocket.bind(Unknown Source)

at java.net.ServerSocket.(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLServerSocketFactoryImpl.createServerSocket(Unkn own Source)

at org.jivesoftware.openfire.net.SSLJiveServerSocketFactory.createServerSocket(SSL JiveServerSocketFactory.java:69)

at org.mortbay.jetty.security.SslSocketConnector.newServerSocket(SslSocketConnecto r.java:395)

at org.mortbay.jetty.bio.SocketConnector.open(SocketConnector.java:72)

at org.mortbay.jetty.AbstractConnector.doStart(AbstractConnector.java:251)

at org.mortbay.jetty.bio.SocketConnector.doStart(SocketConnector.java:145)

at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)

at org.mortbay.jetty.Server.doStart(Server.java:221)

at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)

at org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlug in.java:140)

at org.jivesoftware.openfire.container.AdminConsolePlugin.initializePlugin(AdminCo nsolePlugin.java:175)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :404)

at org.jivesoftware.openfire.container.PluginManager.access$200(PluginManager.java :46)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:916)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Hi,

it seems that stop does not work as expected or takes too long to stop Openfire so the following start fails as the admin console listener (ports 9090 ande 9091) is still active. You should be able to verify this using “netstat |grep 9090” and “ps -ef|grep startup.jar” - this should show that Openfire is still running as some daemon threads take a little bit longer to terminate. If the stop command fails it is save to use “kill -15 PID-of-Openfire” to stop it.

LG

I just tried both of those. I can see the openfire process and it shutdown down cleanly both when i kill it and when i run the stop command. There is no rogue process that i can see. When i run netstat i never see port 9090, althought when wildfire is running i can connect to it. In fact i don’'t see any ports for wild/openfire. Could there be an issue with openfire using the same database as wildfire?

can’‘t be a database issue, i just made a new one and it’‘s the same issue. Also i’'m running java 1.6.0

bump, not a clue from anyone? this is the only thing preventing me from switching permanently away from outlook messenger.

Hi,

you could change

or random other numbers which are not used by your system in conf/openfire.xml if the admin console can not bind to 9091 even if the port seems to be available. Anyhow i have no idea what’'s going wrong.

LG

that was it! when i opened the xml config, the secure admin port was skewed. at first i tried 2 random ports, and everything was fine. then i changed the nonsecure port back to 9090 and left the secure to the odd one and still working. So it’‘s an issue with the port we were using for the secure connection and we’'ll work that out on our own. Thanks much again.