powered by Jive Software

Cannot start Openfire with Windows service

I am running Openfire 3.4.1 on Windows Server 2003 R2 64-bit.

I cannot get the openfire service to manage openfired.exe.

The ‘openfire.exe’ application works fine, but I’m worried that when I log out of my terminal session, I’ll eventually lose the server.

I’ve tried using openfire-service /install, and it does create a service – I’m able to click ‘start’ but no “openfired.exe” ever shows up on the task list.

I’ve done an uninstall and re-install using openfire-service.exe and still the same behavior.

Any suggestions?

Hi Chris,

does “net start openfire” (executed in a “cmd”) or “net start openfired” display something useful? “net start” should not listen Openfire as running.

Does the event log an error?

Do you see errors in the Openfire log files?

Are you using policies which forbid the service to access the Openfire directory?

LG

I just added a shortcut to openfires .exe to C:\Documents and Settings\Administrator\Start Menu\Programs\Startup

and seems to work fine on bootup.