Can't access admin console after install

Hello, I just installed Openfire 3.10.2 on a Centos 7 server like it says on the instructions here:

Openfire: Installation Guide

I did make sure Java is installed:

[root@server conf]# java -version

openjdk version “1.8.0_45”

OpenJDK Runtime Environment (build 1.8.0_45-b13)

OpenJDK 64-Bit Server VM (build 25.45-b02, mixed mode)

The server is listening on 9090:

[root@server conf]# netstat -an | grep 9090

tcp 0 0* LISTEN

But when I try to go to server:9090, it always times out and says webpage not available. What could I be doing wrong?

The /opt/openfire/logs/error.log file is completely empty.

Thanks in advance.

Do you try to login from the same machine or from external? From the same machine try localhost:9090 or

Unfortunately that is not an option because the server only has a command line interface.

Then try using its IP instead of server’s name. If that doesn’t work, check the firewall and try to disable it for a test.

I tried that but no luck. It looks like the IPtables service wasn’t even installed.

I just tried installing apache and I’m able to load the default home page just fine. I’m kinda stumped :-/

What about SELinux? 45.2.7. Enable or Disable SELinux

It looks as though it already was disabled.

I am going to reinstall CentOS and see if it makes any difference.

in centos 7, centos switch from iptables to firewalld. It’s enabled by default, so you’ll need to create firewall rules or disable it.

I’d just like to say I also have this problem on Ubuntu 12:04 using java-7-oracle.

(I’ve, so far, tested with 3.9.2, 3.9.3 and 3.10.2)

On windows I do not have the problem, and I will be making a Ubuntu VM to see if it is some other problem. Hopefully we can get this fixed.

Do you have any output in nohup.out?

It turned out to be a firewall issue. 9090 was being blocked not by IPTables but by the gateway.

Even then, I still had to flush IPTables after I restarted the server.

Thanks everyone.