Can't connect, not even error messages

This is very frustrating with 3.7. While web console is running fine and the logs are all empty, I tried connecting with an Exodus client and it just keeps trying to connect, no error no nothing… Then I tried telnetting from the machine that is running openfire itself to 5222 and sending in the simplified stream example from and there’s no response whatsoever. I know it’s listening to that port at least because telnet opens the connection, but no reply no matter what I type in.

Previously I was using Openfire 3.6.4 on OpenSUSE 11.1 and it was working OK, save for having to regenerate the certifictes every time I restarted the server. I was using the internal database at the time. I had at the time installed it from the .tar.gz

A couple of days ago I upgraded to OpenSUSE 11.4 and figured I’d upgrade Openfire to 3.7. I tried installing from the RPM but couldn’t connect, so I uninstalled, then deleted any leftover openfire directory, and installed from the .tar.gz. This time I used external MySQL. The dB connection seems fine, no errors or anything. I didn’t import the users, just started all from fresh basically.

So what’s going on here? Why is this not working?

Anyone? I’m really stuck here, don’t even know how to troubleshoot. I’ve disabled AppArmor and the firewall is off, but nothing.

Have you tried to use any packet sniffers to see if anything at all is being transmitted between client and server?

I don’t know how to do that…

How would I do this? I really need help to solve this problem…

Use tcpdump ( on your SuSE box, redirect output to file and then you can use Ethreal/Wireshark to analyze dumps. I don’t know what OS you use on your client so can’t advice, if any type of GUI (Linux, Win) you can use Wireshark again.