powered by Jive Software

Can't connect OpenFire to Oracle

Hello evryone,

I’m trying to install openfire 3.7.1 on linux RedHat with Oracle database 11g

I’m facing to the issue and I don’t have any idea to resolve it :

2014.02.10 18:12:48 org.jivesoftware.util.log.util.CommonsLogFactory - Prototype
org.logicalcobwebs.proxool.ProxoolException: Unexpected prototyping problem
        at org.logicalcobwebs.proxool.Prototyper.buildConnection(Prototyper.java:229)
        at org.logicalcobwebs.proxool.Prototyper.sweep(Prototyper.java:102)
        at org.logicalcobwebs.proxool.PrototyperThread.run(PrototyperThread.java:44)
Caused by: java.lang.NoClassDefFoundError: oracle/dms/instrument/ExecutionContextForJDBC
        at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:369)
        at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:164)
        at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:34)
        at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:799)
        at java.sql.DriverManager.getConnection(DriverManager.java:582)
        at java.sql.DriverManager.getConnection(DriverManager.java:154)
        at org.logicalcobwebs.proxool.DefaultConnectionBuilder.buildConnection(DefaultConnectionBuilder.java:39)
        at org.logicalcobwebs.proxool.Prototyper.buildConnection(Prototyper.java:159)
        ... 2 more Caused by:
java.lang.NoClassDefFoundError: oracle/dms/instrument/ExecutionContextForJDBC
        at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:369)

I use the following driver to connect to the database :

http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769 .html

I have this java version :

java -version
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Server VM (build 20.14-b01, mixed mode)

I use this url string to connect to the database server

jdbc:oracle:thin:@<database-host-name>:1521:<SID>

On the openfire host ; sqlplus work, tnsping work…The connection to the database with the oracle account my dba gave me works fine.

I try to put in the lib directory dms.jar but it was worse…

I remove the ojdbc5*.jar in the lib directory, because I’m working with java 6… But It doesn’t help…

Do anyone have an idea ?

Thanks