Can't connect to OpenFire from internet - again

Greetings, new to XMPP and OpenFire here

I’m doing some tests at home before proposing OpenFire at the office. One of the requirements will be that some of us will work from home some times, so access from the internet is a must. But I’m not doing well in that part.

Using OpenFire 4.0.1 over Windows 7, tried latest Pidgin and Spark to connect. Whenever I try to connect to the OpenFire server using, it works. If I use my IP, it doesn’t work. Looking and looking, it seems that the domain must be a fully qualified domain name, so I added an A record to one of my domains, making a subdomain pointing to my current IP. Pinging the subdomain works. The ports are opened and forwarded correctly, as services like tell me 5222 is listening while 5221 is not, for example. OpenFire’s domain is

Again, using the connect address as makes everything possible: creating new users (which I will disable, but well I’m just testing), logging in, etc. When I tell either Pidgin or Spark to use the domain, I can’t connect anymore.

I searched lots and tried lots of different stuff, reinstalled OpenFire a couple of times and rechecked everything so many times, to no avail. I looked in these forums too and while there are some other “can’t connect to openfire from internet” threads, none of which I found are similar to the strange situation I’m experiencing.

Suggestions? Thanks in advance.

Are you trying to login from the same machine Openfire is installed on? Maybe you should try to login from the internet. Outside of your local network (like from a mobile, wifi shared from mobile, ask a friend), not from the same machine.

I can’t try that right now because I have to finish other things but surely will try, thanks. Yes I am trying to connect from the same machine, as as the server address connected.

However I find it quite strange that I can’t use the normal server domain, FQDN, to connect from the same machine. I guess many people would try that after a first install just to check if everything is ok and the server can be connected. And after all, someone will end using a chat client from the same computer running the server.

Juan wrote:

And after all, someone will end using a chat client from the same computer running the server.

Well, not a best practice to do from my point of view. For the security reasons at least. Not saying this shouldn’t work, though (using domain name from the localhost). Just trying to get more information to figure out what’s happening. As i don’t have my servers in the internet, can’t tell for sure how it works. My servers have xmpp domain same as the machine’s name. And if i login in a client from the same machine, it works when using machine’s name (which is xmpp domain). I think it should work in your case too, but here DNS/firewall/NAT/routing/etc can be involved and everything can be a bit trickier.