powered by Jive Software

Can''t connect to other jabber serwer

Hi there

I have Jive Messenger 2.3.0 Beta 1 and some transport, there works fine.

But I can’'t connect to any external jabber serwer.

On firewall I have opened port 5222 clinet port, 5223 SSL both TCP.

What other port should I open?

Plz help me

Best regards

Samson

Go to Server > Server Settings > External Components and set s2s connection settings there. Default port should be 10015.

External components are enable because like I said I have some transports working. Like You said default component port is 10015 so I opened 10015 TCP. But it still does not work.

Help !

Sorry. You have mentioned transports and i did a mistake. You should go to Server to Server menu (above External Components). And you should enable s2s here and the port is 5269.

Also, make sure that the other server has s2s enabled

This is a public serwer.

I have an account there and I can add contacts from other servers but not from mine.

What server is installed there (jabberd, ejabberd, JM, other)? Look in Sessions > Server Sessions. No connection here? Maybe that server had to add your server to whitelist? Check logs for errors or warnings.

Like I said this is a public server so really don’'t know.

I had jive server at home just for fun and sme tests and it worked whell. I was abble to add contacts who are using other jabber server.

Log:

2005.11.04 12:43:18 org.jivesoftware.messenger.spi.ConnectionManagerImpl.startServerListener(Connect ionManagerImpl.java:102) Could not setup a server socket

java.net.BindException: Address already in use

at java.net.PlainSocketImpl.socketBind(Native Method)

at java.net.PlainSocketImpl.bind(Unknown Source)

at java.net.ServerSocket.bind(Unknown Source)

at java.net.ServerSocket.(SocketAcceptThread.java:81)

at org.jivesoftware.messenger.spi.ConnectionManagerImpl.startServerListener(Connec tionManagerImpl.java:90)

at org.jivesoftware.messenger.spi.ConnectionManagerImpl.setServerListenerPort(Conn ectionManagerImpl.java:408)

at org.jivesoftware.messenger.admin.server2server_002dsettings_jsp._jspService(ser ver2server_002dsettings_jsp.java:116)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

Hey samson,

As the message says…the new port that you are trying to use is already in use in your server. If you are under windows you may want to use url=http://www.sysinternals.com/Utilities/TcpView.htmlTcpview.exe[/url] to see which application is making use of that port.

You can search in this forums for common problems when trying to use server-2-server. As a first step you may want to enable the debug log and post any info you get when trying to establish a s2s connection.

Regards,

– Gato