powered by Jive Software

Can't connect to server via localthost:9091 anymore

I have ubuntu server 16.04 with openfire 4.3.2 and Java Version 11. At first it worked fine. But now I can’t access with any client anymore. Even access to console with https://localhost:9091 is not possible anymore. How can I fix that?

Openfire doesn’t support java 11, only java 8. Could you please install java 8 (for example openjdk) and try again?

1 Like

With Java 8 I can login with clients, but https://localhost:9091 is not working!?
And it worked with Java 11 before. And someone in the community posted that openfire 4.3.2 is working with Java Version 11.

What kind of error you get? “Page not found”? Or “Your connection is not secure”?
Can you login via http://localhost:9090 ?

Fehler: Gesicherte Verbindung fehlgeschlagen

  • Error: secured connection got fail
    Die Website kann nicht angezeigt werden, da die Authentizität der erhaltenen Daten nicht verifiziert werden konnte.
    web site connot be displayed, authentification of data cannot be verfied

Can log via http://localhost:9090

This is wrong. Openfire can work partially with Java 11 (launch), but it will have a lot of errors.

1 Like

On port 9091, the admin console is protected by a TLS certificate. If you didn’t install a valid certificate yourself, then a auto-generated, self-signed certificate will be in use.

The certificate contains the domain name of the server. Your browser verifies that the URL that you’re connecting to is the same as that domain name. If it is not, it gives you the error that you’re seeing.

What is likely happening, is that the certificate has the domain name that equals the hostname of your computer, and your hostname changed.

When you login on 9090 what Java version does it show on the first page of Admin Console?

11.0.2 Oracle Corporation – Java HotSpot™ 64-Bit Server VM
But I renamed the Directory of Java 11 (in usr/lib/jvm/java-11-oracle) and when I started openfire new it gave a message that it startet with java 8. But it seems it in parts java 11.

To make it start with Java 8:
stop Openfire (sudo /etc/init.d/openfire stop)
sudo nano /etc/default/openfire
uncomment JAVA_HOME
set to =/usr/lib/jvm/java-8-openjdk-amd64/jre
save it
start Openfire with openfire:openfire user or reboot the server and let the daemon start it

it do not help, no secured login possible!
it shows still: 11.0.2 Oracle Corporation – Java HotSpot™ 64-Bit Server VM
though I removed it completely

I see that it shows Oracle for you. I have only tried it with OpenJDK. So you may try uninstalling Oracle’s Java package and install OpenJDK 11. It should still come with Java 8 (check at /usr/lib/jvm/). Then you can point to Java 8 in /etc/default/openfire and it should take that Java.

Also did you install deb version of Openfire via: sudo dpkg -i openfire_4.3.2_all.deb ?

When i do this on Ubuntu 18.10 it works. But maybe older Ubuntu works differently with Java.

Btw, when it uses OpenJDK it still shows Oracle Corporation, but OpenJDK at the end:

1.8.0_191 Oracle Corporation – OpenJDK 64-bit Server VM

Installation of openfire i do always with double click on ubuntu 16.04 gtk surface.
A restart of openfire wasn’t enough. Complete restart of server solved the problem. Everthing is working fine now with ofenfire and OpenJDK: 1.8.0_191 Oracle Corporation – OpenJDK 64-Bit Server VM.
Thanks for help!