powered by Jive Software

Can't connect to the server

Hi, Sir i tried this command telnet 162.241.146.182 5222
also original public IP address of my server telnet 162.241.71.139 5222

both of the time output was
Connecting To <IP_ADDRESS> 5222…Could not open connection to the host, on port 5222: Connect failed

Note:
1). i’ve 0.0.0.0/0 to my server as allowed ip address
2). i’ve disabled all my windows firewall for now just to test if my spark connects to my openfire or not
3). The log im getting for spark is :point_down:

org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘dc-3887fd21de1e.grevity.in:5222 prio:0:w:0’ failed because java.net.ConnectException: Connection timed out: connect, ‘grevity.in:5222’ failed because java.net.ConnectException: Connection timed out: connect

I have moved your question to a separate post as the other one was old and already resolved.

If you can’t telnet, then there is some issue with your network. Maybe you have disabled wrong firewall or haven’t actually disabled it. Also, in Spark you login to grevity.in. Is this domain name real and recognizable in internet/your network? Can you telnet grevity.in 5222?

i got that i made 5222 public from my server not it worked like a charm