Can't enable HTTP Bind

I’ve looked at all the other posts that mention this error and nothing seems to relate directly or fix the issue. Trying to select “Enabled” on HTTP Bind Settings, I get this error:

“An error has occured configuring the HTTP binding ports, check the error log for more details.”

All other settings on the page seem able to enable/disable/change.

I tried going to Server Manager -> System Properties and manually adding various settings. Not sure if I got the names exactly right but I tried to set these:

httpbind.enabled: true

xmpp.httpbind.enabled: true

Under Log Viewer, the only HttpBind entries I see are (shows up in Error as well as Warn tabs)

at org.jivesoftware.openfire.http.HttpBindManager.changeHttpBindPorts(HttpBindMana

at org.jivesoftware.openfire.http.HttpBindManager.setHttpBindPorts(HttpBindManager .java:448)

at org.jivesoftware.openfire.admin.http_002dbind_jsp.handleUpdate(http_002dbind_js

at org.jivesoftware.openfire.admin.http_002dbind_jsp._jspService(http_002dbind_jsp .java:136)

So not terribly useful information that i can tell.

I don’t see anything else on the default ports (7070 and 7443) that might be conflicting.

I want to enable BOSH so I can maybe integrate a JS based XMPP client so I can get a Chromebox (ChromeOS) to connect to our XMPP/Openfire/Jabber server. Unless anyone has any good recommendations for ChromeOS-friendly XMPP clients (haven’t found any so far).


Remove ‘xmpp.httpbind.enabled: true’ from system properties. Only httpbind.enabled: true is suffice to bind through http-bind. Xmpp port(5222) and bosh port(7070) are different, don’t get confuse with them.

Error points to this code in

public void setHttpBindPorts(int unsecurePort, int securePort) throws Exception {
        if (unsecurePort != HTTP_BIND_PORT_DEFAULT) {
            JiveGlobals.setProperty(HTTP_BIND_PORT, String.valueOf(unsecurePort));
        else {

line 5