powered by Jive Software

Can''t find the Action-> Call optioneven though Asterisk-IM is installed

I just upgraded Jive Messenger from 2.2 to 2.3 and installed Asterisk-IM plugin.

Did the Phone mapping configuration and everything seems to be fine. Untill I started using Spark as the IM client and trying to test Asterisk call, that I realize I do not have the Call option in the Spark IM client. What could be wrong?

I install the Spark Manager plug in but it seems like the Spark Manager couldn’'t locate all my Spark IM client on the network.

I can use Spark to do IM between users with no problem. Please help.

Are the other Asterisk-IM features working? For example, notification of incoming calls and changing the presence?

Regards,

Matt

hmm…seems like the Asterisk-im is not working. I tried calling the mapped extension and it went straight into voicemail. Which could means that it’'s not connected.

The info log shows that Jive has connected to Asterisk successfully. Dones’'t seems to have error on error loh though.

Anything else I can dig out?

I don’'t see the Call option either.

The other features like On the phone and presence work ok, but there’'s no call button to be found. I mapped the phone correctly to the sip account.

Any ideas?

tnx

tom

I am having this problem as well, with Jive Messenger 2.3.0 and Spark 1.0.0. When running locally, the Call option is visible. However when running on the terminal server the Call option is missing. All other features work as expected.

Hi Cameron,

Can you attach the error.log and warning.log files for me to view? I would like to see if there is an exception being thrown during the Phone plugin initialization.

Thanks,

Derek

Me too, I re-install SPARK 1.0.0 and Jive-messsenger 2.3.0 many time, am still not seeing the Call button.

However, when my contact is on the SIP phone, the contact panel does show my contact is on the phone and icon changes accordingly.

Just no CALL button to call my contact !!

I have been follwing this thread f a week, still no answer !!!

Anyone has a fix ? Thanks a million.

Cheers,

Hi Meison,

Could you try the latest with Spark 1.0.1. Also, are you configured to make calls from the Asterisks IM manager? There is a call to the PhoneConnection to check if the phone is enabled, and that is what adds the call button.

Cheers,

Derek

I uninstalled spark 1.0.0, and replaced with 1.0.1. Now the workstation that used to have the call action does not. Should it make a difference if its a softphone? Asterisk is not complaining, and I can make calls. The Asterisk-IM mapping has not changed, nor any other setting.

Perhaps the call button could be added all the time, and spark just errors out gracefully when it can’'t make calls?

Cheers,

Cameron.

Hi Cameron,

Are you using the latest Asterisks Server Plugin? Also if you don’'t mind using a web start version of the app (daily builds), I would love to work with you in resolving this problem.

Web Start: http://liveassist.jivesoftware.com/im/app/spark.jnlp

Hi Meison,

Could you try the latest with Spark 1.0.1. Also,

are you configured to make calls from the Asterisks

IM manager? There is a call to the PhoneConnection

to check if the phone is enabled, and that is what

adds the call button.

Cheers,

Derek

Dear ddman,

I hv upraded to spark 1.0.1.

Question : How to configure to make calls from the Asterisk IM manager ? Which part ? I only have general setting and phone mapping.

Question : I don’'t see the “a call to the PhoneConnection” check box ! Where should it be ?

Note : I hv a Asterisk 1.2.0 in LAN and out at public internet running well on FC3.

Thanks a million !! Couldn’'t wait to see this works for me.

Cheers.

OK, I got it working now.

Really lost track how I did it.

I hv FC3, Asterisk120, Jive_messenger231 and spark101.

I removed all jive_messenger230 and all jars. And reloaded/installed them all.

I too, exec the /opt/jive_messenger/bin/extra/redhat-postinstall.sh script

Now I got the Actions->diall and call button.

Only thing left is although I quit my softphone, jive_messenger’'s session still showing I am on the phone … until I restarted asterisk_im …

Thanks ddman for all the helps and response. It counts really.

Cheers.

Hi Meison,

I’‘m glad you got it working :). It’‘s really a powerful tool when you are using Spark. As for the presence that hangs around, this may be an Asterisks server plugin bug. I’‘ll talk with AJ the main developer for Asterisks here at Jive. I’'ll see if we can get a new release out there pretty soon.

Cheers,

Derek

I couldn’'t make it work.

Should there be a phone software too? Spark doesn’'t do all alone?

I reloaded in Asterisk-IM. Still not working.

However, found something else on the log:

2005.12.08 20:01:53 Asterisk-IM table creation --> Table not found in statement

java.sql.SQLException: Table not found in statement

This should be in Asterisk-IM thread but since I started it here, let’'s continue with this.

Hi Kankgkc,

Which DB are you using? If embedded, I would suggest moving over to another database and adding the tables manually.

Hello Maison,

I have your same problem, could you explain exactly the steps and the software version that you did to make jive-asterisk-spark working correctly?

Thanks in advance

Hi,

I have resolved the problem to find the “Dial Number” button in the “Action” item menu of Spark client. It was a problem of naming; infact I had to connect on Spark client with the FQDN name of the server instead of IP-address.

But now I have another problem; infact when I try to call an asterisk extension on the asterisk console I have the following output:

Dec 14 15:05:41 NOTICE[19791]: channel.c:2424 __ast_request_and_dial: Unable to request channel SIP/’‘namedevice’’

What does it mean??

In the log/warn/debug nothing appear …

But If I have a spftphone in listening the call goes up but for any number I call the call is direct to my number. That’'s very strange!!!

Could someone help me??

Thanks in advance

Hi,

I upgraded to wildfire 2.4, Spark 1.0.2, followed Pinofloyd step of providing FQN instead of ip address, now I can see the Call button.

But I’'m getting exactly the same problem Pinofloyd in his last post (14 Dec) when initiating call.

Anyone out there can advise? Seems like a common problem.