powered by Jive Software

Can''t log in (2.6.1, Jeti)

Jeti craters on login.

Warning log shows:

2006.04.11 20:53:43 Stream error detected. Session: org.jivesoftware.wildfire.ClientSession@9e0c2d status: 1 address: jabber.myserver.net/7436a3c9 id: 7436a3c9 presence:

java.lang.NullPointerException
at org.jivesoftware.util.Base64.encodeBytes(Base64.java:420)

Nothing in the error log, and debug shows:
2006.04.11 20:56:33 SSL Connect 104eabb[SSL_NULL_WITH_NULL_NULL: Socket[addr=/1.2.3.4,port=2334,localport=5223]]
2006.04.11 20:56:33 Logging off jabber.server.net/7b6f3e7d on org.jivesoftware.wildfire.net.SocketConnection@1ce9f9d socket: 104eabb[SSL_RSA_WITH_RC4_128_MD5: Socket[addr=/1.2.3.4,port=2334,localport=5223]] session: org.jivesoftware.wildfire.ClientSession@e3fd79 status: 1 address: jabber.server.net/7b6f3e7d id: 7b6f3e7d presence:

Just upgraded from 2.4.4. (Doesn’'t work with oldssl either, or from Gaim. Admin console works fine.)

Updated, new info in the debug log:

2006.04.11 21:10:03 SubjectAltName of invalid type found: [

[

Version: V3

Subject: CN=jabber.server.net

Signature Algorithm: SHA1withRSA, OID = 1.2.840.113549.1.1.5

Key: Sun DSA Public Key

CAcert again. Same keystore that worked in 2.4.4.

I’'m going to have to put 2.4.4 back in and make another run at it later. The same config (loaded the production db even) worked in 2.4.4. (Edit: Worked on my stage server that is - I loaded the 2.4.4 production database, updated a couple of server properties, manually ran the upgrade scripts and set db version to 7, and it started up and worked.)

Hey Dis,

Could you paste the entire stack trace of the exception? That will help me understand more the steps you were doing and what went wrong. BTW, have you tried with other clients besides Gaim? You may want to try with Spark, Exodus, Pandion, etc.

Are there more errors in the log files? The “SubjectAltName of invalid type found” debug information is not an indication of an error but of a potential invalid certificate. Wildfire 2.4.4 didn’'t have support for SubjectAltName so it was not being used. Anyway, that information is now used for secured s2s communication or when showing information about certificates in the admin console (which I think is you case).

Regards,

– Gato

Hi Dis,

does “manually ran the upgrade scripts and set db version to 7, and it started up and worked” mean that your problem is solved and your question is answered?

LG

The whole trace (from warn.log) is:

2006.04.11 21:10:16 Stream error detected. Session: org.jivesoftware.wildfire.ClientSession@15863e4 status: 1 address: jabber.server.net/1e1f4bd id: 1e1f4bd presence:

java.lang.NullPointerException

at org.jivesoftware.util.Base64.encodeBytes(Base64.java:420)

at org.jivesoftware.util.StringUtils.encodeBase64(StringUtils.java:447)

at org.jivesoftware.wildfire.net.SASLAuthentication.sendChallenge(SASLAuthenticati on.java:341)

at org.jivesoftware.wildfire.net.SASLAuthentication.doHandshake(SASLAuthentication .java:206)

at org.jivesoftware.wildfire.net.SocketReader.authenticateClient(SocketReader.java :317)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:278)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Thread.java:595)

And I tried jeti, jbother and gaim with the same results on all.

That process worked on the staging server. On the production server it didn’‘t. (FYI the postgres upgrade scripts are still broken - it says it updated, but it didn’'t, and even running them by hand leaves the db version at 6.)

Hi,

it seems that Gato (yeah, I’'m blaming him ) did forget the line:

INSERT INTO jiveVersion (name, version) VALUES (’‘wildfire’’, 7);

commit;

… if you run it manually you need to commit the insert.

The update scripts are still missing in the war build, so one may wait for 2.6.1a or 2.6.2 to get a good[/i] 2.6 version.

LG