powered by Jive Software

Can't log in to webadmin, otherwise system seems to be working

About six months ago I set up OpenFire 3.8.2 and it worked fine for a few months. I don’t remember the exact circumstances, but OpenFire had quite running and when I tried to launch it again on the server there were a bunch of errors. I rebooted the server and may have done some other things that I don’t remember and now users can connect with Spark and send messages, but non of the 4 accounts with Admin priviledges can log in to the Webadmin or spark. When trying to log in to the WebAdmin you get the message

“Login failed: make sure your username and password are correct and that you’re an admin or moderator.”

I upgraded to v3.9.3 tongiht which installed fine, but the same issue.

Running on Windows 2008R2 64bit with a local database

I tried doing a fresh install and that works, but if I copy the embedded-db folder from the old install I get the same behavior.

I really need to get logged in to add more staff, I would rather not have to do a fresh install and add all the users and groups manually. Plus this scares me a little bit, what if this does this again? I don’t want to be recreating my users and groups every 3 months.

Any help or thoughts would be appreciated.

You should do frequent backups, so you could do a rollback to the moment when it was working ok.

Probably your database got corrupted during this “quit”. You can try stopping Openfire, edit C:\Program files (x86)\Openfire\confg\openfire.xml like described here in 8-15 messages (don’t miss the UAC part) https://community.igniterealtime.org/message/239057#239057 and add your desired user to admins.

I tried the steps you mentioned and it didn’t work so I did an uninstall/reinstall and recreated all the users and groups. I will implement a backup scheme so that in the future if this happens I have the option to roll back.

Thanks for your assistance.