powered by Jive Software

Can''t login to admin console, fails to load after restart

I recently installed Openfire 3.3.1 on a windows 2003 standard R2 Sp2 system. I was able to install it against our active directory structure, even testing the accounts I set up as admin. Now when I try to login to the admin console I get an error saying that I need to make sure I am an admin… thinking mayhaps a restart was in order I did a restart and now cannot load the admin console at all, let alone log in. Below is the Openfire startup screen messages. Any help on what’'s going on?

java.lang.IllegalArgumentException: Illegal JID: troy_jabber

at org.xmpp.packet.JID.init(JID.java:384)

at org.xmpp.packet.JID.(XMPPServer.java:148)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.openfire.starter.ServerStarter.start(ServerStarter.java:93)

at org.jivesoftware.openfire.starter.ServerStarter.main(ServerStarter.java:49)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

Hi,

“Illegal JID: troy_jabber” looks weird. A JID usually contains a user, domain and resource identifier. Do you use “_” within your domain name?

LG

That was all the tip in the right direction I needed. Thanks!

The server was called troy_jabber, but I shortened it to just jabber. I then re-installed and put the hostname as the full hostname (jabber.domainname.com) and finished up the process. I also turned on one more setting under the groups and all is working.

Thanks again.

I’m having this same issue after having changed the JID to something invalid accidentally. How can I go about changing this if I can’t get to the admin console? (since I can’t start the server…)

Edit:

Looks like I’ve corrected this issue. I opened up /embedded-db/openfire.script and edited the xmpp.domain value. This seems to have corrected the problem without entering the admin console… I’m not a programmer in any way, especially with Java, so the architecture of Openfire is complicated to me. Thanks!