powered by Jive Software

Can''t login with Asterisk-IM enabled

With Asterisk-IM enabled I can no longer connect to the Jive Messanger server with the Spark client. All users receive ‘‘Invalid username or password’’. If I remove the plugin everything works fine.

Hey mocker,

Are you using the latest version of the plugin? Many bugs were fixed since the last beta versions mainly regarding user presences issues. You can also enable the debug log and post any info you get in the warn, error and debug logs.

Regards,

– Gato

2005.11.22 15:08:06 Connect Socket[addr=/

It seems that it’‘s logging me in in the web management portion (I show online), but the client doesn’'t work (using Spark). The client reports back ‘‘Invalid User and or Password’’.

The versions were all just implemented yesterday off of your download page.

Jive Messenger 2.3.0

Asterisk-IM 1.0

Any help would be awesome, we are really excited to see this in action.

Hey mocker,

That log indicates that a session that was never available (but connected) has been closed. Have you enabled the debug log? Could you check if you see anything else like a presence being rejected or something?

Attached to this post you will find a Jive Messenger plugin. Drop it in the plugins folder so we can see the IN/OUT server traffic. The traffic information will be logged to the stdout file. Once you have finished debugging this problem you may want to remove the plugin (i.e. jar file). Post the logged packets so we can see what’'s going on.

Thanks,

– Gato
debugger.jar (10824 Bytes)

RCV:

And thanks a bunch for your prompt reply.

Also getting this sometimes in the warn.log:

2005.11.22 15:40:13 Could not route packet

Is there anything else I can provide to help diagnose my issue?

Hey mocker,

I don’'t see how the asterisk plugin is causing this problem. From the logs it seems that Spark is disconnecting before the session has been fully established. Could you try a couple of things so we can isolate the problem?

  1. Try using another client (e.g. Exodus) and open the debugger to collect the exchanged packets (in Exodus press F12). Let us know if the client is able to log into the server.

  2. Try removing the asterisk plugin and try connecting both with Spark and Exodus.

Regards,

– Gato

Exodus doesn’'t seem to want to play nicely either. This is the Linux version of the server, could that be playing a part?

From the Exodus logs:

Looking up SRV: xmpp-client.tcp.ourdomain.com

Got A:

RECV: SSL status: “SSL negotiation finished successfully”

RECV:

And then I receive a window that says:

There was an error trying to authenticate you.

Either you used the wrong password, or this account is already in use by someone else.

Hey mocker,

Thanks for the input. Have you tried removing the asterisk plugin? Is Exodus able to log into the server when the asterisk plugin is not running? BTW, are the clients and server running in the same machine? Is it possible that you are having some networking issues between the server and the client?

Thanks,

– Gato

I disabled the plugin and was not able to login. I removed the plugin and was able to login instantly[/b].

Asterisk and the Messenger are both on the same server. I know they can communicate because it pulls up the SIP information in the Asterisk IM plugin for my SIP extensions.

Hey mocker,

I really don’'t see any connection between logging in and the asterisk plugin. Have you tried several times with and without the plugin? Can this be an intermittent problem? BTW, I was asking if the client (e.g. Exodus or Spark) were running in the same machine than Jive Messenger.

Thanks,

– Gato

I faced a similar kind of a problem, when i ran the script in the bin/extra folder ''cause jive defaults to embedded database.

Please check if jive is using the same database, when asterisk-im is enabled or disabled.

Also remove jive-messengerd from your rc5.d folder, ''cause i guess jive starts before mysqld and this could cause problems if jive is configured with mysql.

Regards

KIRAN