powered by Jive Software

Can't make Spark 2.7.2 to work on Ubuntu 14.04 LTS x64

I followed this guide http://www.2daygeek.com/how-to-install-spark-im-client-in-ubuntu-14-04/ until step 10a

I downloaded https://www.igniterealtime.org/downloadServlet?filename=spark/spark_2_7_2.tar.gz

On step 9 I didn’t get anything on the file error.log Yet I proceeded to install the libraries hoping to get it to work However I couldn’t launched from the desktop, so I run:

$ /opt/spark/Spark

And get:

Error: Could not find or load main class com.install4j.runtime.launcher.Launcher

I read here Installing Spark IM Client in Ubuntu Linux that it may be a Java Virtual Machine issue so I’m putting my version of java:

$ java -version

java version “1.6.0_24”

Java™ SE Runtime Environment (build 1.6.0_24-b07)

Java HotSpot™ 64-Bit Server VM (build 19.1-b02, mixed mode)

Any help would be appreciated

Message was edited by: Juan Carlos
Fixing a typo

I don’t have Ubuntu 14.04 anymore. But on 15.04 x86 i cd into Spark folder in cmd and run ./Spark (then i just add it to the Launcher and run it from there).

Problem seems to be with x64 architectures. This fellow also has the same problem:
Spark does not start on Ubuntu 14.04 64Bit

I’ve tried Spark 2.7.3 in deepin OS 64 bit, at first in case of error

could not find or load main class com.install4j.runtime.launcher.launcher

then i try to download* install4j.tar.gz *on

https://www.ej-technologies.com/download/install4j/files
then extract the file and copy the folder

.install4j
to the directory where the spark installed. ex: /opt/spark

My Spark successfully executed.

1 Like

Thanks for providing this info. I have filed this as [SPARK-1657] Spark is missing install4j.tar.gz to startup on x64 Linux OS - Jive Software Open Source

You’re welcome,

my English is not so good

Can you try the latest version of Spark and see if the issue is still there? install4j has been updated since then, so maybe the issue is gone.