powered by Jive Software

Can't run 4.6.4 on macos. Anyone running it?

Does anyone have 4.6.4 running on any version of macos? I’ve tried installing it on both High Sierra (10.13.6) and on Big Sur (11.5.2). I’ve tried Greg Wang’s instructions, but no joy. On High Sierra, I get:

Error: JAVA_HOME is not defined correctly.
  We cannot execute /System/Library/Frameworks/JavaVM.framework/Home/bin/java

and running /usr/libexec/java_home gets me:

Unable to find any JVMs matching version "(null)".
No Java runtime present, try --request to install.

I tried installing the latest Java from Oracle and used their utils; still no luck.

On Big Sur, I get a little further, but even using Greg’s instructions, I get:

./openfire.sh: line 185: /Library/Internet: No such file or directory

I haven’t tried installing a new java there yet, but I’d like to know if someone actually has this running on either OS before I continue chasing my tail.

(BTW: The crashing System Preferences pane still exists in either case.)

Well, I discovered some answers for myself. On High Sierra, I installed both the JRE and JDK from Oracle. Once the SDK was installed, I had a proper home and /usr/libexec/java_home returned:

/System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java

Instead of using Greg’s instructions, I simply updated the Darwin portion of openfire.sh to set JAVA_HOME to /usr/libexec/java_home and everything seemed happy to run. I’ll try to get my act together and put in a pull request before long.

That said, trying to stop or start the server from the System Preferences panel still crashes System Preferences. I have yet to go spelunking in that code. That’s a bit more complicated than fixing a shell script.

Bummer that nobody seems to be maintaining this.