powered by Jive Software

Can''t see IM gateway icon on spark

Hi.

I have a fresh install of Openfire and Spark 2.0.8 but i can’'t see anymore MSN or ICQ icon on spark when enable IM Gateway.

Is there something new that i need to do?

I have plugin installed on my server and if i use manual registration my Spark client connect to MSN fine but still not showing MSN or ICQ icon on client.

What’'s wrong??

Openfire 3.2.3, Spark 2.0.8 (tested with lastest beta too) and IM Gateway 1.0

Thank you.

I’‘m not entirely sure. It sounds like Spark isn’‘t detecting the transports for whatever reason. Try firing up Psi or another XMPP client that has disco support and see if you can see the MSN and ICQ transports. If you can, then it’‘s likely something going on with Spark’‘s detection of the transports. (and you will probably want to post in the Spark Support forum about it if that’‘s the case, I don’'t have an intimite knowledge of Spark =) )

I’'d guess this is an issue between Spark and IM Gateway 1.0 (pre 1.0 gateway always detected perfectly)

I had the same issue and detection of gateways works when it feels like it.

However, other clients work brilliantly.

My real concern with this is:

  1. You’'d think there would be some testing/knowledge transfer between the various teams

  2. Spark is the default Wildfire client so it’‘s hardly good for inspiring confidence in the products. I’'d guess people new to the product set would choose to use Spark as a client.

Perhaps what you fail to realize is that I don’‘t work for Jive. So I’‘m not really on any of the “teams”. I’‘m an independent developer that they asked to write this plugin. I’'m basically doing all of this in my free time. (I have a real job)

That said, “typically” what I’‘ve seen happen in the past is that there’‘s some sort of race condition that occurs as you start up the plugin where “something” (probably a client) tries to send something to say, msn.example.org, and the plugin hasn’'t started, so an s2s connection is attempted. Then the plugin starts and takes over msn.example.org and some sort of “confused” state ensues. Usually what fixes this is to go into server sessions, close off any of the msn, icq, whatever instances that exist there, then restart the plugin.

That is -if- that’‘s the problem. I quite frankly don’‘t really understand a lot of what Spark is doing to try to help make the experience more “clean” than other clients. Don’'t really have time to look at it in detail.

Works fine with Pandion client.

I also tried to back to IM 1.0 Beta 8 and didn’'t work.

Looks like it’‘s a openfire problem since i can’'t see pther plugins like broadcast.

So you -can- see all of the plugins/etc with Pandion but not with Spark, regardless of which version of the plugin you are running? Just to make sure, you are actually running Wildfire 3.2.3, right? (not Openfire) The Openfire stuff is going to be painful… there will be a lot of little api changes (renaming of things) that will force me to be putting out an immediately plugin update that works with Openfire itself. '‘salright, but it does mean that I’'ll have to up the minimum version to 3.3.0 (aka wildfire) for 1.0.1 of the gateway. Er… sorry got off on a tangent there.

I’‘m finding it especially bizarre if Pandion can see the various plugins but Spark can not. That leans more towards a Spark weirdism than Wildfire/Openfire itself. But… not sure. I’'m kind of grasping at straws here.

a LOT bizarre.

I’'ve made some tests now…

Wildfire 3.2.2 (old) + IM Gateway 1.0 Beta 8 + spark 2.0.8 = doesn’'t work…

about 2 weeks ago i was using this combination in other sever (but with spark 2.0.7) and was working fine.

I have made fresh install a lot of times, deleting DB and creating again.

Solved!!!

The problem is with spark 2.0.8+

With 2.0.7 everything works fine, including using Wildfire 3.2.3 and IM Gateway 1.0

=( Yikes. Please do report that over on the Spark board! Hopefully it can get worked out.

(wonder what’'s causing it? =/ )

not yet

Wildfire 3.2.3 + IM Gateway 1.0 b8 + spark 2.0.7 = works

after, tried to update IM Gateway to 1.0 and didn’'t work anymore.

Tried to go back to 1.0 b8 and still not working…the only different thing is that now i CAN see other plugins icon’'s like broadcast.

i don’'t know what to do anymore

I’‘m quite perplexed. Anything interesting in the debug logs that might help figure out what’‘s going on? I can’‘t recall, did you check in your Server Sessions window to make sure that the transport JIDs aren’'t showing up there?

Spark gives me this:

28-Mar-2007 14:49:11 org.jivesoftware.spark.util.log.Log error

SEVERE:

No response from the server.:

at org.jivesoftware.smackx.ServiceDiscoveryManager.discoverInfo(ServiceDiscoveryMa nager.java:410)

at org.jivesoftware.smackx.ServiceDiscoveryManager.discoverInfo(ServiceDiscoveryMa nager.java:379)

at org.jivesoftware.sparkimpl.plugin.gateways.transports.TransportUtils.isRegister ed(TransportUtils.java:97)

at org.jivesoftware.sparkimpl.plugin.gateways.GatewayButton.(GatewayButton.java:64 )

at org.jivesoftware.sparkimpl.plugin.gateways.GatewayPlugin.addTransport(GatewayPl ugin.java:166)

at org.jivesoftware.sparkimpl.plugin.gateways.GatewayPlugin.access$100(GatewayPlug in.java:59)

at org.jivesoftware.sparkimpl.plugin.gateways.GatewayPlugin$1.finished(GatewayPlug in.java:98)

at org.jivesoftware.spark.util.SwingWorker$2$1.run(SwingWorker.java:136)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

28-Mar-2007 16:18:03 org.jivesoftware.spark.util.log.Log error

That’‘s exactly the same traceback I’‘ve seen in the past where Openfire got confused about who owned the JID in question. Not sure if that’‘s exactly what’‘s happening here. I connected to my own server using Spark 2.5.0beta3 and I can see all of the icons like normal. ponder I wonder if there’‘s a way I can detect that race condition and at least throw an alert somewhere. (maybe even force the connection to be severed so that Openfire will cheer up) GATE-206 I’'ll see what I can do to make that scenario auto-fix itself.

Of course if this isn’‘t the same scenario… =/ But it sounds like it. The symptom is typically that a client/whatever can “see” the transport JID exists, but can’‘t get anything through to it. No disco requests, no messages, no presence, no nothing. Note that this really is something that ought to be fixed in Openfire itself, as I ran into it a lot during my PyAIMt and PyICQt development… (ie it’‘s not limited to the plugin) However things are happening so fast using internals that it happens a lot more often with the plugin. If I can track down a good way to reproduce it and such I’'ll send it upstream to the Jive folk and maybe finally get it fixed for real. ;D

Not sure if this has anything to do with it, but on my spark client, my aol and yahoo icons are greyed out like if I wasn’'t signed in even though my aol and yahoo contacts are listed and I can send messages to them.

How did you register with the transports? Through the web interface? Through Spark itself? Through something else? Spark uses a “special” mechanism to register, which makes it so the transports don’‘t show up in your roster. Of course it also means that there’‘s more logic in Spark to deal with it, and that other clients won’'t auto-log you into the transports.

Mine’'s the same. In the end I ended up using another client to perform the registration, which then places the gateways in the Spark roster.

However, occasionally (usually after quite a period of time) the gateway icons in Spark begin to operate correctly.

I assume if I had the patience, I could wait for the gateway indications to work correctly, then login using the ‘‘special Spark way’’

More and more evidence that the scenario I was referring to is likely the culprit. =) Thanks much for all this feedback you all! Hopefully we can get this compensated with in some way.

Sorry I forgot to mention it was 2.5.0 beta4

I can’'t remember what client I used to register the accounts so for testing purposes I just deleted the registrations from the admin console.

Starting fresh in spark I entered my login information for Aol, yahoo, and MSN.

After I clicked “save” only the AOL and Yahoo icons are lit. But the MSN icon is still greyed out. But I am still not seeing my gateway contacts.

I then log out of Spark and log back in and all my gateway(aol,yahoo,msn) contacts show up, but the Yahoo icon is greyed out.

Hope this helps.

Daniel,

Whilst you’'re in the mood, and speaking with the Spark developers would you mind telling them about the other incompatibilities? Mainly, the MSN messages that the gateway provides are completely ignored by Spark (i.e. when you attempt to send a message and the gateway is offline, or when you log in from another location).

At the moment, the gateway informs Spark (indicating an error) but Spark just ignores it and pretends to the end user all is ok! Spark 2.5.0 beta 4 also frequently ignores the ‘‘typing stopped’’ notifications that they gateway plug-in sends, which is most annoying!

I have attempted to mention this on the Spark forum and they did say they’'d speak with you!

D