powered by Jive Software

Can''t start my jive messenger2.1.0

hello,

I set up a new server using the 2.1.0 on my Windows 2003 Server, but the server is not start successfully because of the port bind. I checked my services and port,

not finding anything use the port. Then I change the jive_messenger.xml in the conf dir, always it’'s not work. The error is:

2005.03.02 16:38:10 [org.jivesoftware.messenger.container.AdminConsolePlugin.initialize(AdminConsol ePlugin.java:88)

] Trouble initializing admin console

org.mortbay.util.MultiException[java.net.BindException: Address already in use: JVM_Bind]

at org.mortbay.http.HttpServer.doStart(HttpServer.java:673)

at org.mortbay.util.Container.start(Container.java:72)

at org.jivesoftware.messenger.container.AdminConsolePlugin.initialize(AdminConsole Plugin.java:83)

at org.jivesoftware.messenger.container.PluginManager.loadPlugin(PluginManager.jav a:118)

at org.jivesoftware.messenger.container.PluginManager.access$300(PluginManager.jav a:38)

at org.jivesoftware.messenger.container.PluginManager$PluginMonitor.run(PluginMana ger.java:257)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

java.net.BindException: Address already in use: JVM_Bind

at java.net.PlainSocketImpl.socketBind(Native Method)

at java.net.PlainSocketImpl.bind(Unknown Source)

at java.net.ServerSocket.bind(Unknown Source)

at java.net.ServerSocket.(Unknown Source)

at org.mortbay.util.ThreadedServer.newServerSocket(ThreadedServer.java:394)

at org.mortbay.util.ThreadedServer.open(ThreadedServer.java:466)

at org.mortbay.util.ThreadedServer.start(ThreadedServer.java:495)

at org.mortbay.http.SocketListener.start(SocketListener.java:203)

at org.mortbay.http.HttpServer.doStart(HttpServer.java:703)

at org.mortbay.util.Container.start(Container.java:72)

at org.jivesoftware.messenger.container.AdminConsolePlugin.initialize(AdminConsole Plugin.java:83)

at org.jivesoftware.messenger.container.PluginManager.loadPlugin(PluginManager.jav a:118)

at org.jivesoftware.messenger.container.PluginManager.access$300(PluginManager.jav a:38)

at org.jivesoftware.messenger.container.PluginManager$PluginMonitor.run(PluginMana ger.java:257)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

please sb. help me thanks very much.

Another user has reported that Websphere listens on port 9090 by default. Normally, you’'d be able to edit conf/jive_messenger.xml and change the port that Jive Messenger listens on. However, it turns out that feature was broken. We fixed the issue for the upcoming 2.1.2 release as documented in JM-159. I would recommend waiting for the 2.1.2 release. After installing it, try adjusting the admin port to another value besides 9090. Another option would be to find what other service is currently listening on 9090 and shut it down before starting Jive Messenger.

Regards,

Matt